Sen2cor installation fails to define the 3 required variables

Hello all,

I have an issue installing Sen2cor through Anaconda. Everything went well with no single error until this very last step:

The version I am trying to install is Sen2cor 2.4.0 with Anaconda2 5.0.0 (Conda 4.3.27)
My SNAP version is 5 with latest update.
My system is Windows 8.1 64bit.

Edit : or could it be because my anaconda is not in C but in ProgramData? (I kept the default setting throughout install process though)

If anyone can point me to the possible solution to this, or how to set these variables manually

I have also tried the standalone installer before but failed to make it work. I tried the GUI workflow.

Thank you very much,

what happens if you enter “L2A_process” in your command line? I actually see no error in your screenshot.

There is a good tutorial on how to communicate the correct dependencies to SNAP:

Thank you @ABraun,

My problem is that the 3 variables should have been set automatically right? but here it says setx is not recognized as a command…
I will try the described method above and see what happens

I planned to use SNAP’s GUI instead of calling Sen2cor from cmd, but well, I tried at least and this showed

Could it be related to my data and that Sen2cor works fine?

So I am glad to announce that Sen2cor finally worked. I followed all the tried solutions proposed on the provided link above + running it all as admin did it for me.

However the interesting thing to note is that the SNAP integrated GUI sen2cor did not run with an OPER file. The new format (LIC_T could be processed). So I tried running it through cmd with the oper file and finally could have it running.

This will do for the moment because I got the level I wanted for my ROIs on all my data.
Thank you very much @ABraun for your help!

good to hear it worked!