Sen2cor installed sucessfully, but don't does the Level 2A product

Greetings people.

I have a problem with using the SEN2COR plug-in.
I did the whole installation process with no problem (the ones that came out I solved it), and at the moment of using the tool to process a Sentinel-2 image, when I click on “Run”, it gets a few seconds with the load bar in 0 % And then processing stops.
I use the Windows 7, on machine Dell, with processor Intel i5.


is Sen2Cor working properly via command line? If the problem occurs only when running from SNAP, the cause is probably a bad configuration of the system variables. They should be similar to:

Dear obarrilero,

The problem occurs only when running from SNAP, but apparently isn’t a bad configuration on system variables, I tried to correct the problem by this step.

But the following errors persists:

Thank you for attention!


it seems that you are selecting as input a granule of a Sentinel-2 product, but it should be the full product.

Was what is occurrent me!
The algorithm need a short way to past “S2A… .SAFE”.