sen2cor on Windows 7

Continuing the discussion from Installing sen2cor:

I have update the sen2cor to latest version(sen2cor-2.0.6) on windows 7 64-bit.
When i run L2A_process --help I receive the following warnings

Can anyone help me with this issue?. Thank you in advance.

I also installed the new sen2cor version on windows 7 (64 bit) and receive the same warnings and can’t execute the processor.


heres what worked for me:
I replaced \Anaconda\Scripts\openjp2.dll with the openjp2.dll from the previous 2.0.4 sen2cor realease in the software archive, see:

Download the zip-archive and unpack it.
Go to the directory sen2cor-2.0.4\sen2cor\build\ which contains an openjp2.dll.
Replace the original openjp2.dll in your Anaconda Installation ( \Anaconda\Scripts\) with this one.

I am not sure, if this is the correct way to solve the problem!
At least the error warning is gone when i run L2A_Process.
Would be great to get some feedback on this workaround.


Thank you Christian.
It pass the check part but there are other errors now.


Hi Florin,

this error has already been discussed: SEN2COR tool
Basically u have to shorten the path to the L1C root folder, working on Windows OS, because there is path length limitation.

Thank you.
It works.

Hello everyone,

I have also a similar problem with Sen2Cor. I installed Anaconda (2.7), SNAP and Sen2Cor (2.0.6) as described in the manual but I still get this error:

If I replace the openjp2.dll as described above I get an other error:

Is there any solution for it?

Thank you,

Thanks Chris , same problem solved using oldopenjp2.dll
but now I seem to have a failed deletion of cache dir…

Any hint?

I encountered the problem very similar to yours. Have you already solved the problem?

Hi goadiansuan.

No I was not able to solve it. But I was able to install it on my private laptop without any problem. I am still hoping for a new update which will work. :wink:

Hi abgbaumann,

Good to heard it works well on your laptop. My laptop is 32-bit windows system so it seems that it will not work on my laptop as well. It is a pity… So I am also waiting for an updated version of the software.

i had the same problem on windows 7 but when I updated windows 7 to windows 10 problem disappeared. Only problem ( i made a separately topic about it but no answer ) is pixels with no data value after atmospheric correction 10m. ;]


I’ve encountered the same problem when installing sen2cor on a Win7 64bit machine. I previously had it running under nearly identical circumstances on my laptop, but now that I’ve installed it on my desktop PC I’m getting the error message posted above by @abgbaumann.

Are there any solutions or the like for this problem yet?



Ok, problem resolved. In case anyone with the same problem might be interested: I deleted everything again (including SNAP) and then started with installing Anaconda 2.5.0. Afterwards I downloaded, extracted and installed sen2cor-2.0.6 and now it works like a charm.

So I figured deleting SNAP did the trick for me, as I’ve already tried removing Anaconda and sen2cor multiple times.


hi i have the same i tried to do the same as you say but it does not work i always get the same errors
any help pleaaaaaaaaaaaase