Sen2cor processing error "no module named numpy"


#1

Hi all,

I have installed sen2cor 2.3.1 and integrated in SNAP, but when I run it I get the following error

Any idea on how to solve this?

thank you!


#2

numpy should actually included in the Anaconda distribution.

Can you enter “pip list” in your command line and see which packages are installed? If only numpy is missing you can re-install it with “pip install numpy”.


#3

Thank you for your answer!
That problem seems solved, but now when I run Sen2cor the display execution output is totally black and anything is created.


#4

I have tried with the 10 m resolution and it gives the following error (I think that this error is given for each tile)

any help would be appreciated, thank you!


#5

try
pip uninstall glymur

and then

pip install glymur==1.5.0


#6

Thank you!
I have done as you suggested but it returns that it can’t install that version as it is not available.

Now I have noticed that there is another error with the 10 m resolution
AttributeError: ‘bool’ object has no attribute ‘text’


#7

Maybe you find that version here:
http://www.lfd.uci.edu/~gohlke/pythonlibs/

Edit: I saw that 1.5 was not released yet. I would try re-installing the whole Amaconda environment.

Make sure you properly remove all versions of python, sen2cor and so on.


#8

I am getting the same error while using SNAP, even though numpy is installed. I don’t want to go through entire process of installing sen2cor, if it is possible to fix the problem somehow.


#9

I have literally the same problem as @varadi using Sen2cor.
I’ve installed sen2cor step by step with this tutorial: https://www.youtube.com/watch?v=ryGROtiHPYI and the only difference is, when I type “L2A_Process --help” I receive respons like on the printscreen. If I try to execute process in SNAP I receive the same response like @varadi and I also checked that numpy is present in my library. piCan anyone helps? I am not python developer at all and totally don’t know how to deal with it…