sen2cor produces upside-down images?

I tried to apply the athmospheric correction algorithm using sen2cor 2.0.3 not via SNAP but via the command line. Despite some errors during the metadata check, the calculation executes successfully.
But when I open the L1C and the (newly created) L2A image in SNAP, the new image appears to be upside down, like this:

The “weird” looking colors seem to be because of [this already reported][1] bug, but has anyone experienced this upside-down phenomenon?

Best regards,


Addition: While playing around with the data, I found out that if I open the two products and DISABLE the “Synchronize viewing extent position” features (by the way, the tooltip text appears to be wrong, it’s two times the same), I have no problem. As soon as I activate the synchronization, the L2A product created using sen2cor “flips”.

Lat/Lon coordinates seem to be correct for both datasets, and also the “synchronize cursor” feature works. The “viewport position” feature (or whatever it is called) leads to this error.

The “Geometric_Info” in the Metadata is exactly the same in both images, why does SNAP think it needs to “flip” one of the images?


Hi Michael,

can you give me the reference to the product you are using so that I can analyze the wrong coloring phenomenon …

Hi, i tried it using several products, and it was the same in all of them (example). But the wrong coloring is already being investigated as far as I know, see this page in the SEN2COR Bug Tracker. My main “problem” here is the flipped image.