Sen2cor - Syntax error in metadata

Hello all,

I use sen2cor version 2.4.0. The following error appears:

Syntax error in metadata, see report file for details.
Parsing error:
Schema file: S2-PDGS-TAS-DI-PSD-V14.2_Schema/S2_PDI_Level-1C_Tile_Metadata.xsd
Details: Element '{}Level-1C_Tile_ID': No matching global declaration available for the validation root.

At the end of the process appears a mistake:

Syntax error in metadata, see report file for details.
Parsing error:
Schema file: S2-PDGS-TAS-DI-PSD-V14.2_Schema/S2_User_Product_Level-2A_Metadata.xsd
Details: Element 'GRI_List': This element is not expected. Expected is ( GRI_FILENAME ).
Progress[%]: 100.00 : Application terminated successfully.

The process is not interrupted, it is finished. Does anyone know what the problem is, and whether the results obtained L2A levels are valid due to a mistake in the process?


I have the same kind of error from sen2cor integrated within SNAP when processing a S2B

L1C user product directory must match the following mask: S2A_MSIL1C*.SAFE
but is: S2B_MSIL1C_20170725T015659_N0205_R117_T51JUF_20170725T020458.SAFE
Process exited with value 1
Finished tool execution in 7 seconds

I’m processing S2A…

I have the exact same error message and question as davorinbajic while processing S2B_MSIL1C_20171103T111209_N0206_R137_T31UCT_20171106T185400.SAFE

Exactly the same here for file:


It seems to be a change of output format for the manifest file?

It is the same for S2A for the same tile, so it seems to be a mistake in the pipeline of creating the files.

As far as I understood, there was a change in MTD_TL files after October 23rd. Tiles before 23 October sen2cor 2.4.0 processed without errors. After October 23, the above mentioned error appears.

Probably should wait for a new version sen2cor?

Do you have that from an official source? :slight_smile:

Any idea who we need to write to talk about a new sen2cor version?

Obviously they planned to release a new version by mid-October. However…

Thank you @davorinbajic for pointing out which is the actual cause for these errors.
I was struggling as well with some recent S2A and S2B products.

Let’s hope that a new updated Sen2Cor version comes with Santa’s help :wink:

I am bumping this topic because I have the same exact error

Edit : However, the integrated version in snap (not ran through cmd) is working fine, if it is of any help… it still throws the same error but integrated Sen2cor module can bypass this, unlike the one you call with cmd

When you say integrated version in snap you mean in snap 5 or snap 6 ?

Integrated is misleading, I am sorry

I mean, when you launch Sen2cor from SNAP GUI (I use Snap5) it throws the error but the data is still processed

I got the exact same error message. Was there any progress on this? What about the upcoming release as mentioned by @davorinbajic?

New release 2.5.5

I got the same error again with sen2cor 2.5.5. Does anyone know what the problem is, and whether the results are valid ?

1 Like

Same for me with the new version 2.5.5. It seems to be only a warning, but I am wondering if it has an impact on data quality.

I have same error

Has anyone figured out what is causing this in sen2cor version 2.5.5?

I am having the same error. Has someone found out what the issue is?

Dear all,

U have met the same problem. Dose anyone have solutions or suggestions?