Sen2Cor terminates without error or warning

I am trying to process an image from 2016. I changed the GIPP to run the topographic, cirrus and brdf corrections. Standalone sen2cor terminates at 70% without any errors or warnings along the way (except for missing water bodies and snow condition maps but those are irrelevant). I am at loss of what should I do to try to fix the issue. Any help greatly appreciated. I am pretty new to remote sensing (still a student) so if you know what should be done, please explain simply. Thank you in advance :slight_smile:

More info:

  • I am using win10 64-bit
  • Newest version of standalone sen2cor
  • Tried in snap, doesn’t work either
  • Newer image from 2018 with new naming convetion processes in snap without issue
  • Image code: S2A_OPER_PRD_MSIL1C_PDMC_20160805T154608_R136_V20160805T093038_20160805T093038.SAFE
  • I tried to process all resolutions with:
    L2A_Process.bat image_path --GIP_L2A L2A_GIPP.xml

Below is a screenshot of where exactly the process terminates. If any other information is needed let me know.