SEN2COR tool


Thanks, don’t know how I missed that in my earlier searches. L2A_Process now works from the command line, but not through SNAP, where I get the ‘ImportError: No module name Tables’ problem.

I imagine this is because I messed something up in my multiple attempts at getting this to work, but can someone tell me where to troubleshoot this problem? How do I tell SNAP to use the same L2A_Process that I get from the command line?
In the Sen2Cor configuration window, I have the following (I imagine one of these is the problem):
Tool Executable: $PYTHON_BIN
Working Directory: $SEN2COR_HOME
SEN2COR_HOME: C:/Users/aknudby/documents/sen2cor
SEN2COR_BIN: c:/anaconda2/Lib/site-packages/sen2cor-2.2.1-py2.7.egg/sen2cor
PYTHON_BIN: python.exe (which I tried to set to c:/anaconda2/python.exe, to no avail)

No module named tables indicates that a required module might be missing.

You can try
pip install tables

Figured it out. I just had to specify, in SNAP, to use c:/anaconda2/python.exe, as seen below. All works beautifully now.

Hello. PLEASE HELP ME. I tried installing sen2cor according to the recommendations using anaconda2. But when I run I get the information: python does not exist: python.exe.

try to add the full path to your Python installatiom:


Sorry again for troubling you. It seems impossible to work with SNAP. I am trying to use sen2cor and this is the other error that appears. I try to calculate NDVI and also get errors … I do not understand … I hope for your help …

this indicates a mismatch in 32bit and 64bit programs.
Do you have another Python version installed? Which Anaconda version did you install - 32 or 64bit?

32 bit according to my operating system

It would be impossible to install 64bit once I use a 32bit windows

but something in your software says 64bit.

Do you have ArcMap on your PC or anything that also uses python?

Sorry…Yes I have ArcMac; QGis; Erdas imagine and Envi 5.1.

then there is some path in your environment variable which points to the ‘wrong’ python version.
Before installing sen2cor you should make sure that the path to your Anaconda2\python.exe is on top of the path list.

For example:
C:\Anaconda2\; C:\Program Files\ArcMap\Python;C:\Program Files\QGIS\bin\....

also see here:

You should un-install sen2cor before installing it again. You can do this with: pip uninstall sen2cor

Thank you very much, for your patience and help. But it is exact I did before…I Install Anaconda in: C:\Anaconda2…

Sorry…Now I understand… I need create multiple path… For each progam…It is???

the location is not the problem.
The problem is probably that when you type “python install” for the sen2cor installation not the Anaconda2 python is executed but the ArcMap or QGIS python. And this often leads to the 64/32bit error.

To see which python version is used mainly by your system you can enter “python” in your command shell.

Each version of python has its own folder called “site-packages”.
So you should find sen2cor in C:\Anaconda2\lib\site-packages.

they are created automatically when you install the software.
Have a look at your PATH variable and try to move the Anaconda-path in front of the others. But be careful. Each entry must be separated by a ; (at least in Windows versions < 10). In Windows 10 you have a horizontal list with single entries

Thanks for all…I will try…

If you can not, I will uninstall the other programs.

Another question: When I try to calculate vegetation indexes, I also get an error related to buffer creation …

this refers to the memory of your computer. How much RAM do you have?

You don’t need to uninstall all other programs, just temporarily remove their PATH variable or move the Anaconda one up before installing sen2cor so this python version will be used for the creation of sen2cor.

Did you find sen2cor in C:\Anaconda2\lib\site-packages?