Sen2cor value 2

I have installed Sen2cor 2.3.0 successfully. After I try to correct an image, in SNAP environment, I get the error

‘’ Process exited with value 2
Finished tool execution in 0 seconds

I can’t figure it out. I use Windows 10

please have a look here:

1 Like

Thank you for the reply. I already have seen this post and tried everything it describes. The installation seems to be correct but still sen2cor won’t work

what happens when you enter L2A_process in your command line?
Have you tried running sen2cor in the Windows shell? (L2A_process --resolution 10 directory as described in the manual, chapter 3.2.1)

Can you please post a screenshot of the parameters of sen2cor? You find them under Tools > Manage external tools > sen2cor > edit > System Variables.

What I get when I try to to run sen2cor in the windows shell is

C:\AZ>L2A_Process C:\AZ\Imagery\S2A_MSIL1C\S2A_MSIL1C.SAFE --resolution=10 --sc_only
Traceback (most recent call last):
File “C:\Program Files\Anaconda2\Scripts\”, line 11, in
load_entry_point(‘sen2cor==2.3.0’, ‘console_scripts’, ‘L2A_Process’)()
File “C:\Program Files\Anaconda2\lib\site-packages\sen2cor-2.3.0-py2.7.egg\sen2cor\”, line 169, in main
File “C:\Program Files\Anaconda2\lib\site-packages\sen2cor-2.3.0-py2.7.egg\sen2cor\”, line 3072, in setSchemes
self.logger.fatal('wrong identifier for xml structure: ’ + product)
AttributeError: ‘NoneType’ object has no attribute ‘fatal’

you must not change the name of the .safe-folder after downloading.
Use the original name and it should work.

I had the same problem as Peterk31.
I tried to follow the suggestions of this forum, but it seems not working.
All that I obtained is this

is there anyone who could give me further advice to solve the problem?

Thanks a lot


Hi Sara,

do you have the same error with other input files? When you try to open the L1C product with SNAP desktop, does it work properly?

Thanks for your answer.
I actually founded the problem: I was making a mistake in the environmental variables’ paths.It seems to work now.

Thanks again


Hi Sara could you tell ma what was your mistake in the env variables , I am facing he same pb
Happy new year