Sen2cor280 graph builder

I am trying to convert 4 files from S2A_MSIL1C TO S2A_MSIL2A using the sen2cor280 tool in the graph builder. when i try and build the graph SNAP maxes out my computer for about ten minutes when I try and connedct the read and sen2cor boxes.
screenshot shows the operation I am trying to do and the ubuntu sysytem monitor. after about ten minutes the arrow will complete, and i can try and add a write box. this leads to a complete freezing of the computer for a long time ( so long that i turned it off!)
Is this normal behaviour?

How much resources have you granted for the SNAP Java VM?

edit: In any case that should not happen as you are only building the graph and not running it. Which SNAP version are you running (hopefully the very latest one)

I don’t know how much resource I’ve allocated to SNAP java, how would I find out?
I’m running the latest SNAP, (I assume) the updater runs every time I start SNAP.
I’m answering this from another machine, after being frozen for 10 minutes after right clicking in the graph builder to add a node the computer unfroze, so like a fool I right clicked again and it’s back up to 100% on both processors!

edit: after ten minutes it unfroze again and i could add the write module, but when i tried to connect it, back up to 100% on both processors.
for some reason it has also created the S2A_MSIL2A… folder at each time that i do anything to build the graph?

edit2: I have now saved the graph,
mcsen2cor.xml (2.8 KB)
When i try and load it into batch processing i get the following error:

See under Tools/Options/Performance … SNAP can adjust the values for you based on the amount of RAM you have.

Thankyou @mengdahl I have doubled the RAM, but it still doesn’t seem to do any better!

External tools are not well usable in the Graph Builder.
How the Graph Builder works does not fit well to how external tools work.
There is an issue in progress: [STEP-6] Standalone Tool Adapters in Graphs - JIRA (

Beside this, the memory consumption is not in full control by SNAP. Because the external process is using memory too.

1 Like