Sen2Coral Empirical bathymetry .csv not recognized

Hello,

I’m trying to get a bathymetry in shallow water with the Sen2Coral Empirical bathymetry tool, but the tool does not manage to recognize the points from the .csv I am loading.
I check the projection and they way it is done in the Sen2coral tutorial and can’t find why it is not working!

Would anyone have a solution for that?

Thanks,
Maureen

can you please share

  • a link to the tutorial you are referring to
  • the product ID of the satellite image you are using
  • the csv you are using

This is the tutorial:

The tile I’ve download:
S2A_MSIL1C_20200208T101151_N0209_R022_T32TPN_20200208T103320

The csv:
image

thank you. Please upload the CSV using this button grafik so I can test it myself

bathy_32n_orbetello.csv (155 Bytes)

Thank you ! There it is

these points are over land - is this intended?

By now, I can reproduce your error. I also get the message that no valid points are contained. But I will try a some options.

When I modify the data (remove the - sign) I no longer get this error, but a OperatorException:
bathy_32n_orbetello.csv

grafik

Have you tried another product? I keep to have problems with this tile.

Hello,

I took the points from a LiDAR data (terrestrial) so I tried to be on the closest to submerged land but I did not have actual bathymetric data. I think I might need to get better data for the in situ part.

I will try with another tile then, I only tried with this one, and ask the RUS team about this type of error too.

Thank you !!