Sen2Three 1.1.0 not compatible with Sen2Cor 2.5.5

Hi,
I’ve installed the latest versions of Sen2Cor (v.02.05.05) and Sen2Three (v.1.1.0). I ran some tiles through Sen2Cor and then tried running them in Sen2Three but got error messages related to the MTD_MSIL2A.xml file.

I’ve found that .xml files created by the latest version of Sen2Cor are not compatible with the requirements of Sen2Three. I know this is the case because I managed to get Sen2Three running on some old data we had lying around processed using a older version of Sen2Cor. Comparing the new and old Sen2Cor MTD_MSIL2A.xml files, there are mostly cases were “L2A_” string is missing in the newer version. However, there are also other changes.

I’ve raised the issue on Sen2Three github:
https://github.com/umwilm/SEN2THREE/issues/1

Dear Omar,
thanks for the reply!

Where can I find the Win installer of older Sen2Cor version? Could you please advice the good way to re-install the plugin so it works fine together with Sen2Three 1.1.0?

Cheers. Filip

Hi kegro!

this seems to be an issue still. I have process Sentinel-2 data L1C (for 2019) with Sen2Cor-02.08.00 and there is a L2A_” string is missing. This means that sen2tThree-1.1.0 on the S2 L2A processed using data Sen2Cor-02.08.00 does not work . Any news regarding this?

Or potential ways to get around this issue?

Many thanks,

Sorry ecdg, couldn’t find a way around so I dropped it.

I am also giving up sadly. Thanks for the reply anyways :slight_smile: