Sen2three-1.1.0: release announcements

Sen2Three 1.1.0 is now released. Details on the release can be found here:

In contrast to Sen2Cor release 2.4.0, Sen2Three is currently still provided as an anaconda site package. There is a planning to integrate it in the new Sen2Cor stand-alone installer, but no concrete release date is decided yet.

It will be announced in this forum, when the integration exists.

Test Data Sets
Due to the considerable size of the products, we do not provide a separate Test Data Set. Users are encouraged to download e.g. the following products from:

Known issue

At date of release, the following issue can occur on CentOS 6.1 (other Linux distributions might be affected as well):

Syntax error in metadata, see report file for details. Parsing error: Schema file: L3_GIPP.xsd
Details: Element ‘PSD_Scheme’, attribute ‘PSD_Version’: [facet ‘length’] The value ‘’ has a length of ‘0’; this differs from the allowed length of ‘2’.

This is a bug in the libxml2 library version 2.9.4 installed by Anaconda 2.4.0 which is used in the Sen2Three module for reading and validating the XML configugarion files and metadata. The XML files itself are correct, but are not correctly validated by the XML parser. Thich leads to error messages during execution. Details on this problem are further described here:

The solution is, to downgrade the libxml2 library to the version 2.9.2 which does not have this bug. This is done by typing the following command via command line:
“conda install libxml2=2.9.2”.

The observed error has no influence on the correct processing of the L3 data. As we have no control on the future evolution of Anaconda, (which will probably fix the bug in the future), we do not perform this package downgrade during our installation.

If you observe any further issues during installation of Sen2Three under Anaconda, please reply here, under this thread, with an explicit information on which operating system the issue occurred. We will then try to provide recommendations. Please, do not open a new thread for this purpose, as it will be difficult for us to track the problems, if multiple threads with the same issues exist.

1 Like


I have tried using Sen2three-1.1.0. I have a question on the processing of images from Sentinel 2 of year 2016. I am unable to run the process of Sen2three for the 2016 images even though I have processed them into Level 2 products.

I understand that this version are able to process images from Dec 2016 onwards with the higher version of PSD. However, could it be that it is not possible to run Sen2three across the PSDs? E.g. from Jan 2016 to Dec 2016? Or could it just be that my installation has gone wrong somewhere?

The error displayed on the log is “TypeError: ‘bool’ object does not support item assignment”.

Thank you.


I tried to downgrade using the command you show however I receive the error below.
Is there a suitable package in place of this one? I tried to search the Conda site for one however there are many and the one I did select did not seem to work.

PackagesNotFoundError: The following packages are not available from current channels: