Sentinel 1 data : terrain correction


#1

When I use my sentinel 1 data to do terrain correction, the default “srtm 3 sec” keeps on processing without stop. But it is very slow process. This process does not finish for 5 hours.
I was processing data just like this tutorial:
http://sentinel1.s3.amazonaws.com/docs/S1TBX%20SAR%20Basics%20Tutorial.pdf

Can you tell me what is the problem?

plz help me.
Thanks all…


#2

I have had similar problem and the cause was company proxy. During terrain correction DEM is being downloaded and something can be blocking this. I changed the network and it was fine. Check logs in Help -> Show log directory, there were errors about connection.


#3

Dear #zubro
I do not understand what you say. please help me for solving this problem.
Thanks


#4

Range Doppler Terrain Correction tool is downloading data while processing - it is downloading digital elevation model automatically if you chose SRTM (auto download). In my case my company intranet was blocking this download and the writing message was displayed for 3 hours and nothing happend as in your case. I have just changed the internet network from company intranet to company open wifi and it was working. So try to change internet network because something can block tool to download data it needs.


#5

But i am already use open wifi and it is not working.


#6

Download the DEM manually and use it in the TC module. Choose “external DEM“ instead of SRTM.


#7

Sir #ABraun,
plz send me link for Downloading the DEM manually.
Thanks…


#8

http://dwtkns.com/srtm/


#9

@ABraun
How would I use the external SRTM DEMs?
Every time I try to use an external DEM, SNAP ignores it.


#10

They must be projected in WGS84 (not UTM) and cover the image, then it should work.
How do you know that the external DEM is ignored?


#11

Sorry for the late reply. I’ve been ill.
I projected my DEMs into WGS1984 (not UTM) and made sure my mosaic of SRTM 1 Sec DEMs covered my entire radar image. The resultant mosaic actually covered a lot more than my radar image. Sadly, it still did not work. I plan to try clipping my DEM to match my radar image, see if maybe that helps.

I know that the external DEM is ignored as the product produced when I select an external DEM is identical to the product produced by the SRTM 1 Sec autodownload option. The result only covers a tiny portion of my radar image and does not match the extents of any of the 1 Sec tiles or the mosaics I’ve created and told SNAP to use.

My location is the Erta Ale volcano near the Red Sea if that means anything.


#12

@knicely Just a hint - try with ASTER DEM from USGS. I made this with SRTM, ASTER and local DEM - it worked fine for me. Tiles from USGS have with smaller size and if you investigate small region this could speed up.


#13

@ABraun, @hriston_bg
I’ve realized my problem was the computer I was working on. It was an old machine and wasn’t running SNAP correctly. I moved onto a more modern computer and everything worked perfectly. Thanks for your effort.


#14

As always hardware is the starting point.


#15

i faced the same problem. Use projection as a Wgs 84/utm zone in the processing parameters tab.
worked for me. All the best!