SLC to PRI SNAP utility Error:The file parameter is not set

Hi, I am getting this error when trying to run the SLC to PRI utility on a subset of an ALOS SM slc image. the procedure worked fine on the first 3 images but then this read error started to appear. The subset is run with everything checked that can be checked in the Band Subset, Tie-Point and Metadata tabs. The “Data Format:” check box is empty when loading the subset. The subset virtual intensity bands have been converted. The original ALOS image file reads fine when entered into the SLC to PRI utility. I can not locate the traceback error window.

I don’t see the Subset operator in the SLC to PRI graph, can you please illustrate your problem with screenshots?

The subset, SLC to PRI window and error…thanks

Have you tried to save the subset in BEAM DIMAP format before you run the SLC to PRI operator?

Also, is there a reason why you use this specific tool chain? It is more common to apply calibration and the Terrain Correction.

I had converted the subset virtual bands. Following your suggestion, I just saved the subset to the BEAM DIMAP format before running SLC to PRI. the operator again failed, though it gave a different error msg pasted below.
I used the SLC to PRI operator on three previous ALOS subset images and it ran fine on all 3. I’m not running Terrain Correction because its easier to identify change pre TC. there was an unexpected power outage (if might have happened after completing the first set of 3), so reinstalled SNAP just in case. I’ve tried the SLC to PRI on 3 additional and different ALOS subset images and the same problem occurs.

can you open and display the input bands of the subset after saving the product? My feeling is that the input product is already corrupted by the subset of virtual bands.

hi, yes both HH and HV subset bands open and seem to have the same range of intensity values. I calibrated the subset to sigma and the process seemed to run fine.

sorry, I should have added to my last msg… both HH and HV subset bands open and seem to have the same range of intensity values as the full image.

PolSARpro cannot work with Sigma0 values, it needs the original i+q parts of the radar product.

thanks, I was just checking if the subset could be opened by another process than SLC to PRI.

is it an option to create the chain of operators yourself (in the Graph Builder) and apply it to the input images?

I’m a novice SNAP user and haven’t used Graph Builder. unfortunately I have a approaching time constraint. if if I was able to pick it up quickly maybe I could attempt.

I have created the graph for you graph.xml (2.3 KB)

Please try if you can load it into the graph builder and apply it to the first image.

okay, thanks, apply it to the original or subset image?

try the subset and if it throws an error, the problem is probably caused by the creation of the subset. If you want, you can also put the creation of the subset at the beginning of the graph as well (after Read).

especially if you are new to SNAP and have little time - wouldn’t it make sense to process your data manually? First create the subset, write the product, then calibrate > write, then SRGR > write, and so on. This lets you keep track of the quality of the data and helps to avoid errors like this.

true, however, the SLC to PRI worked great until the error occurred.

I ran the graph script starting with the subset and there was a read error, subSamplingX >0.0.

I followed your suggestion " First create the subset, write the product, then calibrate > write, then SRGR > write" when running the SRGR got the error
image image

I used a subset of a TerraSAR-X Stripmap image and also get an error:

@lveci @jun_lu is this operator still working as intended?

As an alternative - it would make sense to apply radiometric calibration (optionally followed by multi-looking) and then create a stack of the products (using coregistration) to search for changes. If you have found changes, you can terrain correct the changes.

My feeling is that the SRGR operator is rather outdated.