SliceAssembly op after EAPPhaseCorrection op

I’m getting an error when trying to apply the SliceAssembly op to two S1 products (IW mode), which have been previously EAP-calibrated by the EAPPhaseCorrection op. The error message is:

Error: [Node:SliceAssembly(2)] String index out of range: 48

If I reverse the order (i.e., first SliceAssembly, then EAPPhaseCorrection), I get another (not really informative – to me at least) error message, namely:


These are the products I’m using:


Would you have any pointers?



Dear Dev Team,

Would you let me know if there are any plans to address this issue in the next release?



I tried it with these two products running the EAP first and then slice assembly. I didn’t get any error. I used a build from teh master branch.

I’ve tried again and found the issue:

The name of the input product for the SliceAssembly op should have the original zip file name as prefix.

I guess this should be retrieved from the metadata, but I have a workaround for now.


Dear Dev Team and Esteban:

I am experiencing the same error reported in this thread:

I did change the name to the files, so I was wondering if it is just a bug regarding filenames, and whether there are any other ways to address it.



Could you list the file names of the slice products? Thanks