SLSTR subset error: The pixel region is invalid

Hi everyone.

I have an issue subsetting Sentinel-3 SLSTR data. Probably it does not find enough overlap between the data and the AOI? If that is the case, there should be a more informative error message appearing. However, the metadata clearly shows an overlap between my AOI (the Alps) and the product coverage.
The input file is: S3A_SL_1_RBT____20211229T085439_20211229T085739_20211230T234617_0179_080_164_2160_LN2_O_NT_004.SEN3

I tried with both Snap GUI and GPT, same error: Error: [NodeId: Subset] The pixel region 'java.awt.Rectangle[x=0,y=0,width=0,height=0]' is invalid.
Snap and the plugins are up to date with the latest version. I attach the graph used.
I am getting this error with many SLSTR files, if needed I can provide a list of them.

Kind regards,
Michele Claus
Eurac Research

SLSTR_subset_reproject.xml (2.8 KB)

Hi Michele,

In the saved XML file, the region and the geoRegion are set. The region has precedence over geoRegion. The value is 0,0,0,0.
If you remove it, the graph will probably work when you load it again.

Thanks for the suggestion Marco, but unfortunately it does not seem to solve the problem, I still get the same error.
I tried without setting the parameter (using the notation <region/>) and removing it, no differences.

~/snap/bin$ ./gpt SLSTR_subset_reproject_error2.xml 
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
INFO: org.esa.s2tbx.dataio.gdal.GDALVersion: Incompatible GDAL 3.4.3 found on system. Internal GDAL 3.2.1 from distribution will be used.
INFO: org.esa.s2tbx.dataio.gdal.GDALVersion: GDAL 3.0.4 found on system. JNI driver will be used.
INFO: org.esa.s2tbx.dataio.gdal.GDALVersion: Installed GDAL 3.0.4 set to be used by SNAP.
INFO: org.esa.snap.core.util.EngineVersionCheckActivator: Please check regularly for new updates for the best SNAP experience.
INFO: org.esa.s2tbx.dataio.gdal.GDALVersion: Installed GDAL 3.0.4 set to be used by SNAP.
Executing processing graph
INFO: org.hsqldb.persist.Logger: dataFileCache open start

Error: [NodeId: Subset] The pixel region 'java.awt.Rectangle[x=0,y=0,width=0,height=0]' is invalid.

Without the subset works fine, but it is just a workaround not a solution.

SLSTR_subset_reproject_error2.xml (2.9 KB)
SLSTR_subset_reproject_error.xml (2.9 KB)

You have to define 5 points in your polygon, and the last one and first one should be the same to close it properly. I see six point in your polygon definition.
For instance:
POLYGON((0.407 51.341, 0.407 51.764, 1.208 51.764, 1.208 51.764, 0.407 51.341))

1 Like

Thanks for the suggestion but again, it does not solve the issue! By the way, it works fine with 6 points on other files. I attach here the process graphs:
SLSTR_subset_reproject_working_6_points_polygon.xml (2.9 KB)
SLSTR_subset_reproject_error_5_points_polygon.xml (2.9 KB)

The issue is related the my AOI (Alps) + the SLSTR acquisitions covering the eastern part of it, acquired around 08:54 AM.

Additionally, it is SNAP GUI that automatically duplicates the last point in the polygon:
I insert 5 points:
after moving back and forth to another tab like reproject:

I’ve created a ticket for this issue: [SNAP-1577] Graph Builder automatically duplicates the last point in a polygon

1 Like

Thanks Marco and Ana. I hope you will find some time to try out the graphs that I provided and understand what’s wrong with that SLSTR data. These are part of the files I am processing and for these ones I am getting the error:

Moreover, changing the order of reprojection and subset does not solve the issue, same error.
If I do reprojection only I can clearly see that there is an overlap with the data in S3A_SL_1_RBT____20211229T085439_20211229T085739_20211230T234617_0179_080_164_2160_LN2_O_NT_004.SEN3:

I just found what’s wrong.
The problem are the oblique view bands. They cover only the eastern part of the scene. This the intersection with your AOI is empty. This has not been observed till now.
This is one of the oblique bands in SNAP with your AOI.

So, in this case the subset operator should skip such bands instead of causing an error.
If you can work with the nadir bands only an option is to exclude the oblique bands in the subset step and include only the nadir bands.

Also, for this I’ve created a ticket: [SNAP-1578] Subset operator should ignore bands which do not overlap with AOI