SNAP 5.0 Installation Error in Windows 10 SOLVED


#1

Hello all,

I am a relatively new SNAP user and I am having an issue with the installation of SNAP. The installer is giving the error pictured below:

The error log reads as follows:

java.io.IOException: The filename, directory name, or volume label syntax is incorrect
at java.io.WinNTFileSystem.createFileExclusively(Native Method)
at java.io.File.createTempFile(Unknown Source)
at java.io.File.createTempFile(Unknown Source)
at com.install4j.runtime.installer.helper.LoggerImpl.(LoggerImpl.java:65)
at com.install4j.runtime.installer.helper.Logger.getInstance(Logger.java:50)
at com.install4j.runtime.installer.helper.Logger.getImpl(Logger.java:73)
at com.install4j.runtime.installer.ContextImpl.(ContextImpl.java:145)
at com.install4j.runtime.installer.InstallerContextImpl.(InstallerContextImpl.java:52)
at com.install4j.runtime.installer.frontend.InstallerWizardScreenExecutor.(InstallerWizardScreenExecutor.java:19)
at com.install4j.runtime.installer.Installer$2.run(Installer.java:99)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
java.io.IOException: The filename, directory name, or volume label syntax is incorrect
at java.io.WinNTFileSystem.canonicalize0(Native Method)
at java.io.WinNTFileSystem.canonicalize(Unknown Source)
at java.io.File.getCanonicalPath(Unknown Source)
at com.install4j.runtime.installer.InstallerVariables.initSystemVars(InstallerVariables.java:553)
at com.install4j.runtime.installer.InstallerVariables.initCommandLine(InstallerVariables.java:621)
at com.install4j.runtime.installer.Installer.getScreenExecutor(Installer.java:111)
at com.install4j.runtime.installer.Installer.runInProcess(Installer.java:58)
at com.install4j.runtime.installer.Installer.main(Installer.java:46)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:62)
at com.exe4j.runtime.WinLauncher.main(WinLauncher.java:101)
at com.install4j.runtime.launcher.WinLauncher.main(WinLauncher.java:26)

This is a new laptop which I successfully installed SNAP on yesterday, however, I was having separate issues with the sen2cor plugin. In an attempt to find a solution, I uninstalled SNAP and was presented with the error upon trying to reinstall. I tried redownloading the installation file to ensure it was not corrupted with no luck. I am unsure where to go from here and any help would be appreciated.

Thanks!
Colin


#2

That’s an error I haven’t seen before.
Have you restarted your laptop? Maybe the was still process hanging from the uninstallation which hold a directory.


#3

It apparently had something to do with the administrative privileges on the computer. I had been assigned temporary administrator privileges, but they had apparently been reset by a network push. Someone with administrative privileges from our support group was able to successfully reinstall. Thanks!