Snap 7 shows only 4 bands...?

hi all
i have installed snap 7 on a debian machine and i don’t know what happened but it shows me only 4 bands on the s2b sentinel image. in qgis it finds all images.
is the a problem with snap 7
can i revert to snap 6 (worked fine)

many thanks in advance…

Would you please to share the product name? (identifier name)

did you open the product via the menu? File > Import > Optical > Sentinel-2 > S2 MSI L1C


i tried with the zip and without.

i tried via the menu. same result.

i am trying to download a fresh image see if that one opens normally…
(and i hope im not doing something really obvious or stupid…)

hi there
not that i have any idea whats the difference in the download protocol or how it came about to loose all the other bands - here is another image i downloaded and it looks ok???..
a mystery…
ill be very happy for ideas - just so i can confirm if im doing something wrong or what…
cheers for listening

We downloaded the same product (for which you only saw 4 bands), and it seems OK:

Can you try to download it again?
(maybe something got corrupted, in the last 2 weeks there were some network issues with Copernicus Scihub that caused download failures) see Download S2 L2A Data from the Copernicsu Open Access Hub

thanks for your quick reply…
i agree, i have already downloaded 20 other images and they do seem ok (i randomly checked few).
it is a mystery!
in any case, i am calculating indices and will attempt bulk processing so i guess you will here from me again…
thank you all

how large is the SAFE folder of the product (the one which only has 4 bands)?

Maybe you can cross-check with the size of the one @oana_hogoiu has downloaded to see if your download was maybe incomplete.

Correctly downloaded .zip size:

1 Like

same size…
like i said - in the

i see them images…