Snap 8 on Windows11

Is SNAP working in Windows 11? I had it installed on win 10 then the os got upgraded to win 11 and it was still working fine. But I uninstalled it and it’s not installing now. The problem is with the install4j wizard as it is not throwing up the setup window. Does anybody have any solution?

For me it is working. I just tried it.
Has the installer correctly been downloaded?
Can you start it from the command line?
You could invoke it some options like:
esa-snap_sentinel_windows-x64_8_0.exe -Dinstall4j.debug=true -Dinstall4j.log=c:\snap-install.log
More are options for the installer are shown here: install4j Help - Command line options

The created log file (of course you can change the path) would be helpful to identify the issue.

Hi marpet, thanks for the reply. I tried the command and the problem still exists although I got to know why it isn’t working. I have attached the screenshot below. I’m trying to resolve it in the meanwhile if you have any solution please let me know.

Thanks in advance

Apparently, updating/repairing the old Visual C++ Redistributable solved the problem and I could install snap without any error.