Snap closes after splash screen during plugin update

I read that the program had similar issues in the past (2017/2018)
I have windows 10 pro with NVIDIA GeForce RTX 2060 SUPER, 64 gb of memory and a SSD disk of one terabyte. No Java installed in my pc.

Log attached.

messages.log (59.1 KB)

The last entries in messages.log:

INFO []: System network proxy resolver: Windows
INFO []: Windows system proxy resolver: auto detect
INFO []: System network proxy reloading succeeded.
INFO []: System network proxy - mode: direct
INFO []: System network proxy: fell to default (correct if direct mode went before)

Years ago there was an issue with IPv6. You could try

There may be more information in Windows Reliability Monitor.

The log file you have attached looks fine. The tip @gnwiii write might be worth testing.
Another thing you could try is to update the driver of your graphics card.

You could also try to update SNAP to the latest version from the command line.
How to do it is explained here:
Update SNAP from the command line - SNAP - Confluence (
the command would be:
snap64 --nosplash --nogui --modules --update-all

Many thanks for your support

I did all those things actually and still the same problemno_updates

Apparently no updates available and I used adding it to the Snap Optimization Configuration. Is that correct?

[Please paste text directly into your posts – images are often difficult to read on laptop screens and are not searchable]

Using the command-line rules out a graphics driver issue. “Updates not found” suggests a network problem. Are you using a proxy? If you are using IPv6 and can switch to IPv4 that is worth trying. Does “Reliability Monitor” show any issues at the time SNAP fails.

Try .nbm files for offline install . If you can’t download the updates with a browser try a command-line method (curl or wget) which give lots of debugging parameters to pinpoint the issue.

I assume your post under .nbm files for offline install was meant for this thread. It is unfortunate that this problem falls into a category that is difficult for an individual to resolve. If the underlying issue is network related you may encounter failures for downloads from other sites.

In my career I have spent many hours sorting out network problems for my workgroup. In recent time this generally involved careful documentation of the failures that I passed to out IT people, who then worked with the network managers or remote site’s IP people to sort out the problems. Large organizations have been adding layers of security to their networks that often require tweaks to support use cases other than web browsing and Outlook email.

I found a solution that I know is brutal but it works.

I installed Ubuntu 20.04 in the WSL on my Win10 Pro.
I installed a desktop environment (XCFE4) on the WSL/Ubuntu machine
Installed SNAP in Ubuntu and GWSL for accessing X11 software from Win 10.

Thanks again for your help

Are you using WSL1 or WSL2? If snap in WSL can be upgraded and is working that rules out most internet issues, so points to Windows or Java network settings.

Java proxy setup in Windows might be helpful.

WSL2. I agree with you on the most likely causes and I have a feeling that is Java and probably some issue of compatibility with Nvidia GPU video cards. I also removed WorldWind jar file to see if that was the problem but no luck.