SNAP coregistration of a stack ignores the last image

Hello user group -

Earlier today I reported an issue in which SNAP coregistration of SAR images quit working when the initial offset information comes from georegistration. It was working a couple of months ago and now it does not. It occurred to me that there is another issue that I have not yet reported.

If you use SNAP to do coregistration of a stack of images, and there are more than 2 images (more than 1 slave), then the final interpolated registered slave image in the stack has no content — it is all zeros.

If you have one master and one slave, it appears to work OK.

Thank you…

Hello users group -

I ran into a problem using SNAP for coregistration of PALSAR-2 images (Radar -> Coregistration). It worked fine a couple of months ago, and I’m wondering if something changed in a recent SNAP update.

In setting up the parameters for doing the coregistration, I tell it to use geolocation information rather than orbit information. However, when I click “Run,” it says that there is no geolocation information in the file, but the file is a geoTIFF file.

Again, this worked just a couple of months ago, so I’m not sure what has changed. In fact, I tried running the coregistration on the exact same images that I ran successfully a couple of months ago, and this time it failed, so it appears that something changed in SNAP.

Thanks for any help that you can provide…

I merged both topics.

I don’t think the number of images is the problem. Are the three images of different orbits? e.g. img1 and img2 are ascending and img3 is descending.

These images are part of an InSAR collect, so they should be on the same orbit.


Coregistration is based on a random initial distribution of GCPs which are then tested for correlation throughout all images. That means if it worked one time there is a chance that it fails another time by simple chance. You can increase the number of GCPs and run again. If this doesn’t work, you can also test DEM-based coregistration.

Yep, I’ve tried it a number of times, and it always gives me the same error, saying that there is no geo-coding in my geotiff file.

I’ve used this successfully in the past on geotiff files, so I’m confused.

Did you just open the tif file or did you import the ALOS product via File > Import > SAR Sensors?
The latter is required for SNAP to read all metadata correctly.

Here’s what I do:

Radar -> Coregistration -> Coregistration

A dialog box comes up, and at top right is a “+” sign that I click N times in order to bring in N files. If this is not correct, PLEASE let me know.

This worked successfully in the past, but perhaps something has changed.

Again, the files I’m am trying to coregister are not CEOS, they are GeoTIFF.

Does the band list of the coregistration tool show all metadata (track, date) correctly?

It does NOT show the track. However, I would not expect the file to have track information since the files are GeoTIFF and not CEOS.

I have noticed that the dates are NOT correct.

I’m still a novice SNAP user. I’m open to any suggestions about loading metadata. I assumed that loading the files individually into the coregistration tool was sufficient, but apparently it’s not.

Where did you download the data and in which product level (1.1 or 1.5)?

I downloaded the data from EastView Geospatial, a company in Minneapolis Minnesota, USA. They are a distributor of PALSAR-2 data through an agreement with JAXA. They do not do the processing themselves. They have it processed by whoever does the processing for JAXA.

The products are GeoTIFF 2.1.

Level 2.1 is already terrain corrected, not the best input for coregistration.
Do you have the chance to get the level 1.1 ceos product as well?

You can try this software and test if it imports and processes your data correctly: GITASAR: SAR image processing for beginners

I tried one of your suggestions and got an error that may be indicative of my problem.

I did this:
File -> Import -> SAR Sensors -> ALOS2 GeoTIFF

and I got this error:
No appropriate product reader found.
Can’t find reader for the given format ‘ALOS2 Geo TIFF’.

Perhaps I have a problem with my installation?

Could it be that this product level (2.1) is not suppoerted by SNAP?

Try GITASAR, it is a good tool!

Can you point me to the download site? When I search on GITASAR, I get links to the meaning of life according to Bhagavad gita saar hindi…

Please find all downloads in this post: