SNAP Coregistration Resolution Issue

Hi there,

I’m trying to coregister a slave raster (5m/pixel) using a higher resolution master raster (2.5m/pixel), yet I end up with an output having a scale problem. I’m running the tool with default processing parameters. Anybody has an idea, how to resolve the problem?



I don’t know the GeFolki coregistration very well, but would it make a difference to resample the coarse image first xso they have the same spatial resolution before the coregistration?

That’s a good idea and it works, thank you very much for the suggestion! On the other hand, it might be a bit unpractical if same master is intended to be used for different resolution slaves of the same area, i.e. Sentinel-2 and Landsat-8 bands. In this case, 6 resampled masters have to be created : (

I agree, if it really does what is promised in the documentation, the resolution of the inputs should not play a role.

Is the tool really needed, or maybe the classic coregistration does the job as well?

Not sure for the necessity of this tool actually :slight_smile: I searched for the coregistration tool options and ran across GeFolki. I’m open to all suggestions :pray:

Depends on your input data - what do these rasters come from?
Do they have any spatial reference?

Slaves are Sentinel-2 and Landsat-8, whereas master is orthoimagery…

EDIT: I didn’t realise the second part at first, sorry. All in UTM coordinates…

the geocoding of optical data is mostly quite good
if all have the same spatial coordinate reference system, you could use the collocation tool and select the ortho-image as the reference and Sentinel-2 and Landsat-8 as secondary products

Sounds great!! I’ll give it a try, and comment again. Thank you so much :blush:

Unfortunately it didn’t work for me, because I still need positional correction rather than resampling. I would like to eliminate the heterogeneous offsets completely…

then I suggest Radar > Coregistration > Coregistration.
The product on top of the list is the reference, make sure that you select “product geolocation” as initial offset method.

That’s really amazing! Adapting radar tools for optical data never crossed my mind. I tested it and seems like it gives great results! I really appreciate that, thank you so much…

1 Like