SNAP Desktop will not open

I just downloaded SNAP desktop (windows 64bit) and when I open the application I see the loading window. It Disappears as soon as it gets to “Done loading modules” and nothing happens. I can’t even get into the program. I downloaded everything with the default settings.

Any suggestions?

Try disabling your internet connection before the start for once. Had a case where this worked, at least to see if it is network-related.

No luck, but thanks for trying to help

Are you behind a proxy? This can make problems.
If yo this might help:

It can also be helpful if you could post the log file.
To find it press WINDOWS+R and then type appdata
Navigate to C:\Users\<username>\AppData\Roaming\SNAP\var\log
Please post the messages.log file.

messages.log.2 (22.6 KB)

There is my log, I do not think I am using a proxy. Should I just try to download an older version?

Another idea:
Can you try to run SNAP as administrator?
If you have installed SNAP as admin, then this might be a solution.

Still not working :weary:

update I downgraded to version 5 and it looks like it works. very strange