SNAP doesn't recognize selected image view

So I loaded a couple of different band combinations of a stack of pre-processed Sentinel-1 images and worked on them for a few hours. As soon as I tried to normalize the colour distribution of one of the views, the image views started wreaking havoc:

  • panning is super-fast at times (not sure when exactly, most of the time it works) – i. e. the view moves a lot faster than my cursor such that I end up seeing some grey area far away from the image.
  • I can’t do anything in the Colour Manipulation window – it says “[…] Right now, there is no selected image view.”
  • The layer manager is empty.
  • I have synchronized image views enabled but they barely ever synchronize (still sometimes two of the five views of the same image do synchronize.

I re-started SNAP twice and always got the same behaviour very soon after I loaded the second image view of the same image.
I haven’t tried re-starting my machine yet as that takes about 15 minutes. This is on Windows 7 with SNAP 5.0.4

Any ideas why this happens?

Not sure if this is related but when I try to create an HSV image window, I get a java.lang.NullPointerException. Creating an RGB image window works like usual.

Add: The HSV problem seems to be related as it always occurs when the selected image view is not recognized and I’ve never had it happen when it is recognized.

I move your topic into the S1TBX section. Probably it is more related to the S1 data then to the general behaviour of the tools. I haven’t seen this behaviour on S3 data for example.

What your saying about the too fast moving cursor sounds like wrong coordinate reference systems.

Can you tell what type of S1 data do you use and how you have pre-processed them?

How is your computer equipped with RAM? Do you have enough? This might be the cause for the other problems you report. But I’m just guessing right now.

I use IW_GRDH level-1 data directly downloaded from Scihub.

I think the pre-processing steps were: orbit file, spatial subset, TNR, cal, terrain flatten, remove speckle, terrain-correction, then stack about 10 images together.

I have 64 GB RAM. The image file itself was less than 2 GB and I had only one file open. I had a lot of image views of that file open, maybe a dozen or so.

I have barely used SNAP lately and hence haven’t experienced this again.