SNAP doesnt work?

My SNAP software does not work, I can open the data but non of the processing functions are not working, do you have any idea why this might happen?

What OS are you using, and which SNAP version?
It worked good until now?
You can try re-installing SNAP from scratch.

on windows 10, using the latest version of SNAP, I assume version 7.0, yes it was working good till 2 days ago,

OK. What you mean by “none of the processing functions are working”? The processing doesn’t start, it throws an error, or … what is the behavior?

The process does not start, no reaction, might it be related to windows firewall settings or sth? I tried to re-install the software and still problem exist

Check in Task Manager the memory usage. Maybe there is not enough memory to run the processing you need. Or maybe there are hanging processes that you should manually stop from previous attempts.
Also check SNAP log file, you can find it in the directory indicated in Help -> Show log directory. (the most recent messages.log)
Try to run SNAP as administrator.