SNAP error "appropriate reader not found"

Dear all,

Since my last update (today) I cannot load Sentinel-1 zip data on SNAP any more : SNAP error “appropriate reader not found”.
The file is, SNAP used to open it without problem before. The zip is not corrupted. I tryed with other data and the same problem appeared.
My SNAP version is 4.0 and Desktop implementation version 4.0.2, and my operatiing system is elementary OS 0.3.2 from Ubuntu 14.04.

Does someone have an idea ?

Maybe there is a problem with the rest of the path like special characters. Try moving the product file into a folder you know shouldn’t have an issue like your home folder.
It could be another reader interfering or maybe the s1tbx modules are not loaded. Do you see the radar menu?
Try unzipping it and opening the metadata.xml file.

Thank you for such a quick answer.
I can’t see the radar menu anymore.
I tried in a different folder but didn’t worked.
I can’t open it even when I unzip it, I load the file (It is probably the same as metadata.xml) but I have the same problem.

It sounds like somehow the Sentinel-1 Toolbox has been removed or not installed.
Check if you can update it from the Tools/Plugins window.
If not, you may need to uninstall and reinstall SNAP making sure that S1TBX is included.

Thank you for your help, I reinstalled SNAP and it works now.

Hi all,

I have the same type of problem when I try to open a Sentinel 2 file :

Could anybody help me with this ?




for Sentinel-2 data, you select the MTD file, not the manifest file