Snap Error in opening zip file

hello everyone,
I face an error during range Doppler terrain correction. Type: OperatorException, Message: error in opening zip file.
How to correct it, please guide.
Thank you.

we are already aware of this issue: SRTM ZIP-files are corrupted or not found

ABraun sir,
even after putting external DEM still the same error is showing.

sorry, then it is another issue.

Did you input the external DEM as a zip file?
What happens when you select SRTM 1Sec (AutoDownload) as DEM?

Are you sure that the path is correct where you put the files in?

The error message “error in opening zip file” indicates that it is the same problem. So if you delete the corrrupted zip file and put a non-corrupted zip file of the DEM there it is unlikely that this error message still appears.

1 Like

sir I tried both, SRTM 1Sec(AutoDownlode) and external DEM in tif file (SRTM of the same study area), but the error remain same.

sir I downloaded the SRTM VOID fill data from USGS Earth Explorer. I didn’t delete any file, I just put the tif file of it in the External DEM. I don’t know why the same error is showing after trying all the things discussed above. Kindly guide.

As suggested by @bart-lg please go to your SNAP user directory (C:\Users\username.snap\auxdata\dem…) and into the SRTM 1Sec folder and delete the zip files in there, especially those with a file size of 0 kb.
Then please run the Terrain Correction again with SRTM 1Sec AutoDownload set as DEM.

Once a faulty file was downloaded SNAP tries to use it for the processing.

yes I deleted the zip file inside the SRTM 1Sec AutoDownload & SRTM 3Sec AutoDownload,
processed again but still the same error is showing. May be sir somehow Autodownload is not working properly.

Was the 0 kb file created again by the AutoDownload?

What error message do you get when you insert the external DEM?

now there is no file created in AutoDownload. before it was 1 kb zip file.
Error i got from inserting external DEM remain same. i.e, Type: OperatorException, Message: error in opening zip file.

Same problem here! I tried all steps and downloaded srtm .tif file to use it as external dem, but still have that message…
I also deleted all files downloaded inside AutoDownload folder in auxdata. I’m working with SNAP version 8.0. In version 7.0 it works properly.

hope this helps, cheers!

just to go sure - are all updates installed?

Yes Andreas!

and did you test both SRTM 1Sec and 3Sec?

As reported here, re-installing SNAP 8 (including the deletion of user configuration data) fixes the error.


It does indeed!
I performed the re-installation and included deletion of all data and now it works fine. Many thanks A.!

good to hear, thank you!

the SNAP I am using ver 9.0 does not open zip files (I have downloaded several S2A and S2B files and they can’t be opened. It reports that snap does not have a reader for that kind of file. I have installed in my computer UnZipper and Winzip and no solution occurs. I have tried putting on the PATH variable the path to UnZipper but no solution shows up. If there is any one that can help, thanks

Can you check if “Sentinel-2 Toolbox Kit Module” is in the list of installed plugins (Tools → Plugins → “Installed” tab)? For more details, please have a look at Cant open Sentinel 2 in SNAP 9.0.0 .

Hi Diana_harosa: Thanks for your answer. I did check but it is installed “Sentinel-2 Toolbox Kit Module”. Afterwards I went to the link you provided me, but no solution appears there.I am working in a Hewlett Packard All in one computer with Windows 11, with the unzip application UnZipper. Thanks again