Snap/gpt subset incorrect output extent

Hi I encounter quite interest issue when using SNAP (either GUI or gpt, version 8.0.5, OS: Linux Ubuntu 20.04) .

I try to subset a sentinel-3 OLCI image I downloaded from NASA OCEANDATA
[Update: also download the same tile from:, same issue]

when I tried to subset this image after download and unzip, I found the output extent of the subset image is incorrect (the north is short). subset command I used is:
gpt Subset -PgeoRegion='POLYGON((-84 41.2, -84 42.9, -78.4 42.9, -78.4 41.2, -84 41.2))' -t test_extent.dim S3B_OL_1_EFR____20210817T161406_20210817T161706_20210818T211821_0179_056_040_2160_LN1_O_NT_002.SEN3/xfdumanifest.xml

in the downloaded full tile RGB, a pin with in the subset extent (lat<42.9)

while the same pin is outside the subset:

I tried to turn on the S3TBX & disable tie-point coordiantes, but not seems related.

more interesting is, if I subset to a smaller area:
gpt Subset -PgeoRegion='POLYGON((-83.08 42.27, -83.08 42.69, -82.35 42.69, -82.35 42.27, -83.08 42.27))' -t test_extent_small_correct.dim S3B_OL_1_EFR____20210817T161406_20210817T161706_20210818T211821_0179_056_040_2160_LN1_O_NT_002.SEN3/xfdumanifest.xml
then the north extent is correct.
any clue?