Snap gpt Terrain-Correction

Hi, I need an hint for being able to perform terrain correction from terminal using gpt. I would like to apply UTM Zone 32 / World Geodetic System 1984 projection to my final data instead of lat/long. I was able to do it using the user interface but I get errors when I run from command line. I used the option -PmapProjection=‘UTM Zone 32 / World Geodetic System 1984’ but it was a wrong guess :frowning: Can anyone help me on this? Otherwise I’ve already prepared my xml graph as workaround…


Moreover, I noticed a strange behavior for the pixel spacing… when you insert the unit in meters then it is automatically converted it in degree (and vice-versa). However, the measure is not “stable” it changed as soon as you click on the degree box…In the end anyway seems that the pixel spacing in degree is “winning” and deciding the pixel spacing in meters in the final image… Is it supposed to perform the correction in lat/long as standard (and having also a dem in lat/long)?


When selecting a projection it usually has a lot of other information needed for that projection. Save a graph from the graph builder using the projection you want and copy all those parameters to the command line. But the easiest way may be as you suggested just using the graph at the command line.

1 Like

I think it also worth noting that the Terrain-Correction operator (and probably others as well) also accept EPSG and AUTO codes as the projection parameter. These are usually much more convenient to use.
All of the following projection parameter values produce an image in the “UTM Zone 32N / World Geodetic System 1984” projection:

  • a WKT string:
    PROJCS["WGS 84 / UTM zone 32N",GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.01745329251994328,AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4326"]],UNIT["metre",1,AUTHORITY["EPSG","9001"]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",0],PARAMETER["central_meridian",9],PARAMETER["scale_factor",0.9996],PARAMETER["false_easting",500000],PARAMETER["false_northing",0],AUTHORITY["EPSG","32632"],AXIS["Easting",EAST],AXIS["Northing",NORTH]]
  • an EPSG code: EPSG:32632
  • an AUTO code (automatically picks the appropriate UTM zone from the provided coordinates): AUTO2:42001,lon,lat