SNAP GUI Near Stagnant Write Speeds ( < 1mb/s)

I am wondering if anyone else has had this issue and found a solution. I’ve been attempting to use the S-1 Slice Assembly on two GRD products. It has taken nearly 4 hours to get to ~50%. Two days ago, I did the same thing with the process taking less than a minute. The problem seems to lie in the write speed. If I cancel the operation, and try again with the same parameters, it will quickly jump to the ~50% within 30 seconds, and then it stagnates once again. With my disk speed sitting at around 1 mb/s (the processor just seems to be chilling, it doesn’t go above 1% at this point). This is split about evenly between read/write. Watching the values as SNAP over-writes the old file, the processor jumps to about 100% and the disk speed also jumps to 100-300 mb/s. This might also be because the old file is still in memory? If I change the file name it will also jump up to around 50%. I don’t really know how the read/write process is supposed to work, so feel free to enlighten me.


While doing a performance computation with SNAP Configuration Optimiser, the disk speed hovers around 100 mb/s and the calibration takes a standard amount of time. If I do a similar calibration within the SNAP toolbox, the disk reads similar values of less than 1 mb/s.

With SNAP closed, moving large files around isn’t an issue and the disk speed is again at around 100 mb/s. I only seem to encounter low disk speeds in the write process of SNAP. Otherwise, I would say its a problem with my hard drive. What also baffles me is that I had this problem about a week ago, and then one day everything seemed to go back to normal. As mentioned earlier, slice assembly was no problem, taking less than a minute. Now yesterday, the problem has returned and it seems to be even worse than before.

Same problem 5-6 hours on every step for generate SAR interferogram, totally over 48 hours for a single sar on windows 10 pro, i7 8th generation octacore but without SSD, using a WD10SPZX-80Z10T0 1Tb SATA Disk 5400 rpm, but i think even i replace the hard disk with a faster one the problem will persist.

Are you using SNAP7.0 with all the available updates installed?

Yes, i use the latest version with auto update checked. Also i have 16Gb RAM memory and the HDD empty. I have increased the java memory to 8Gb or 6Gb, i have disabled the hard drive cache from device manager disk properties, disabled windows defender and switch to developer mode, from 9 S1A_IW i choosed only one segment from 9 to minimize the computer usage but now the SNAP software doesn’t work anymore shows me the error: GC overhead limit and sometimes Java heap space. Next days i will purchase a new computer with over 64Gb Ram, SSD…i don’t see any other solution.
On Linux it’s working well under the same computer, but for my project i need this SAR files compiled and recorded on windows.

You are encountering strange issues - the specs of your computer are sufficient.