SNAP log file and errorr on exection


I am facing a problem integrating Sen2Cor with SNAP. As I run Sen2Cor, the GUI is not consistent with the one in the help. There is not any option for choosing the output location.

Then when I press run, the following error happens:

Here is what is logged:

WARNING [org.esa.snap]: Opening target product by guessing the plugin failed [File not found: F:\S2-27lakes\S2A_USER_PRD_MSIL2A_PDMC_20160907T044118_R008_V20160905T104022_20160905T104245.SAFE\S2A_USER_MTD_SAFL2A_PDMC_20160907T044118_R008_V20160905T104022_20160905T104245.xml]. Trying by extension.
INFO [org.esa.snap]: Building product reader - EPSG:32740

You can find the SNAP log files by choosing Help / Show log Directory from the menu.
There is the messages.log file which contains the log of your current SNAP session.
The log files with numbers attached contain the log of your previous sessions.

I think sen2cor writes additional log information. I Don’t know where.
You can make the output visible in SNAP by enabling the option ‘Display execution output’ on the Processing Parameter tab.

This might give you already some more hints what’s going wrong.

Thanks for the tip about the log file. I have updated my question to make the problem clearer.


does “F:\S2-27lakes\S2A_USER_PRD_MSIL2A_PDMC_20160907T044118_R008_V20160905T104022_20160905T104245.SAFE\S2A_USER_MTD_SAFL2A_PDMC_20160907T044118_R008_V20160905T104022_20160905T104245.xml” exist in your file system? Which is the path of your input product?

No, the file and the folder does not exist. Shouldn’t it be created by the application?
This is what, I guess, is missing in my GUI as it is shown in the below pic:

The input address is:


When you use the sen2cor plugin, you cannot define the output name, it is automatically set by sen2cor.

The sen2cor plugin is a “Tool adapter” for sen2cor: it builds the command line for executing sen2cor, it waits till sen2cor finish and after that, it tries to read the output product that should be generated. In your case, there is an error because the plugin cannot find the output, so I think that there is something wrong with your sen2cor installation because it seems that it is not creating the output.

Is sen2cor working properly when you execute it from command line?

I followed the step of this manual, so when I run ‘L2A_Process --help’ I receive the correct information. Though I don’t know how to run the Sen2Cor process from the CMD.

Try with this:

You have more information on page 35 of the manual you have indicated.

Hey, Thanks for your help.
The sen2cor problem is resolved however I now receive the following error when I am processing my data:
File “C:\Users\username\AppData\Local\Continuum\Anaconda2\Lib\site-packages\sen2cor-2.3.1-py2.7.egg\sen2cor\”, line 324, in init
INFO [org.esa.snap]: if not ‘USER’ in tiOld.text:
SEVERE [org.esa.snap]: AttributeError: ‘bool’ object has no attribute ‘text’

Is it a bug or is it because of version differences between libraries?
How should I fix this?

Some similar errors have been reported and some of them were solved by deleting the L2A product generated by sen2cor in a previous failed execution.
You can also try to execute sen2cor with another product to check if it is a problem with your product or with sen2cor.

I ran the process with a new product and there is a new error:

UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xd6 in position 22: ordinal not in range(128)

It is interesting that for two different products I getting two different errors.
I think there is a problem with sen2cor. what you think and what you suggest to resolve the problem?

Which is the path of your new product? Is there any non-ascii character?

I solved the ‘bool’ error with downgrading libxml2
conda install libxml2=2.9.2

I also have the same problem…can you help me out ???

Hi @Mounika,

there are different problems described in this post, could you please describe your problem? What versions are you using?

hello obarrilero,

I was getting the following error. earlier i could perform atmospheric correction successfully. I was unable to fix it. Please help me out from this issue.

Thanks in advance

Hi Mounika,

there are some post about the “No module named glymur” error. Perhaps they could help you. Please see:

On the other hand, have you tried the stand-alone installers of Sen2Cor? They are much easier to install.