SNAP not opening products after updating to 7.0.3

About 2 hours ago, I’ve updated SNAP 7.0.2 to 7.0.3 (Windows 10). Unfortunately, since that moment I haven’t been able to open any product. I’ve tried both .zip & .dim files, dropping onto Product Explorer, via File/Open Product, via File/Reopen Product, via the icon Open Product… but nothing happens. Anybody else having the same experience?

Hi, could you please verify that are the plugins are activated in SNAP -> Tools -> Plugins -> Installed?
Sometimes it has been reported that if the download of the updates is corrupted some of them are deactivated and it is not posible to activate them again.

In this case, the easiest would be to reinstall SNAP and to make the update again.

Two days ago I was trying to address the Java problem, I work on Windows 8.1, I tried after updating to SNAP 7.3 that I work on data (GRD-SLC) does not work, I tried with many versions of Java without interest…
These are messages

Question, what is the appropriate version of Java which is on window 8.1 and supported SNAP7.3

The appropriate Java version is shipped along with SNAP. It is 1.8_u202.

The error you show is not a problem of the Java version but of the amount of memory you have. How much RAM does your system have?

Actually this error doesn’t related to java itself, however, the properties of your machine and the graphics card driver should be updated.

Dear Omar,
I suppose that could be the reason indeed. I can’t check that anymore because I have uninstalled 7.0.3 and installed 7.0.0 to be able to go on with my data for that moment, but now I let SNAP update again, checked the plugins (all of them active) and everything seems to be working well. Now I know how to handle such a situation if it would repeat in future. Thank you very much!

Vga: NVIDIA Quada K2200

In this case, one solution is, to update the SNAP, properties to be compatible with the machine, take a look at the following post,

Source of the post

Other solution is, uninstall it, and re-download the installer and install it again.