SNAP on virtual machine

Hi,

I would like to know is there any known issues or limitations for SNAP if it is used on a virtual machine?

I have the latest SNAP version installed on virtual machine that has CentOS 7 x64. This system has 20GB of RAM and 150GB of
free space in hard drive. Whenever I try to process the SLC to GRD I get warning “cannot construct data buffer.” I found that this is a common problem, but after trying all found suggestions in STEP forum SNAP still processes SLC files to GRD very slow compared with actual PC with similar specs.

S.

The only known issue I’m aware of is that the World Wind View can make problems. It is caused by the limited 3D support in the VM. This is only a problem in the Desktop application, if SNAP is used only from the command line it is not an issue at all.

I assume that you are using gpt. Have you set the Xmx option in gpt.vmoptions?

Hi,
In my PHD student, and in my research, mapping deforestation in the Amazon rainforest, I need to process many S1 images (time-series images). My research area is smaller than one sub-swath (5 bursts). I’d like to know the possibility to use a virtual machine from ESA. My machine is not good and my processing is taking too much time. I think I will have enough time to complete in time my research. I never used the virtual machine. Can you give me some information about this topic, please? Are these virtual machines for free for students?

Thank you very much,

Claudia Arantes

For access to the ESA virtual machines, please consult the Copernicus RUS service: https://rus-copernicus.eu/portal/the-rus-service/how-does-rus-work/

Thank you ABraun,
I did my registration but I didint find where I need to go to ask for a machine.

Claudia

After login you go to “Your RUS Service” where you find “Your dashboard”

Thanks ABraun,

The Request button is not available to fill and ask the service.

Maybe it’s better to ask directly in the RUS forum: https://rus-copernicus.eu/forum/

Any reason why you want to use SLC products (instead of GRD)?

The reason is that I’m not from Europe Union.

Because I’m using Coherence and amplitude.

alright, I understand. Just wanted to go sure if there’s a chance to reduce the amount of data.

ESA cannot provide computers to our data/software users. Copernicus RUS provides some in a limited manner. If your local machine is slow please make sure to tweak the performance settings in options and to use short graphs (in case you are running ou of memory).

This is my configuration.
What exactly should I change?

Try pressing “Compute” on the top-side, save changes and restart. You need to run SNAP with admin privileges to be able to change the values, at least on Windows.

Check also the “Use filecache” in S1TBX-settings if you are running low on memory.

ps. these settings are frequently discussed on the forum, use search to find out more. .