Snap quit unexpectedly using MacOS El Capitan 10.11.6

After viewing a band and using the “Worldwind Analysis View” Tool Window, I quit SNAP and selected “No” for “Do you wish to save it?” popup I got a “Problem report for SNAP” Window. The contents of the “Problem Details and System Cnnfiguraton” are:

Process:               java [25328]
Path:                  /Users/USER/*/jre.bundle/Contents/Home/jre/bin/java
Version:               1.0 (1.0)
Code Type:             X86-64 (Native)
Parent Process:        sh [24450]
Responsible:           java [25328]
User ID:               5137

Date/Time:             2016-08-12 07:14:00.511 -0300
OS Version:            Mac OS X 10.11.6 (15G31)
Report Version:        11
Anonymous UUID:        E96CD0A7-1F35-9CBC-2523-D201016677EB

Time Awake Since Boot: 2000000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  AppKit Thread  Dispatch queue:

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000018
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x18:
    __TEXT                 000000010149e000-00000001014b0000 [   72K] r-x/rwx SM=COW  /Volumes/VOLUME/*/jre.bundle/Contents/Home/jre/bin/java

Application Specific Information:
abort() called

Thread 0 Crashed:: AppKit Thread  Dispatch queue:
0   libsystem_kernel.dylib        	0x00007fff96389f06 __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff8cf304ec pthread_kill + 90
2   libsystem_c.dylib             	0x00007fff994b96df abort + 129
3   libjvm.dylib                  	0x0000000103c82beb os::abort(bool) + 25
4   libjvm.dylib                  	0x0000000103da6a2a VMError::report_and_die() + 2304
5   libjvm.dylib                  	0x0000000103c84816 JVM_handle_bsd_signal + 1131
6   libjvm.dylib                  	0x0000000103c80a7b signalHandler(int, __siginfo*, void*) + 47
7   libsystem_platform.dylib      	0x00007fff8980352a _sigtramp + 26
8   ???                           	0x00007fff5e75c8a8 0 + 140734778165416
9   ???                           	0x000000010479e954 0 + 4370065748
10  ???                           	0x0000000104790c4d 0 + 4370009165
11  ???                           	0x0000000104790c4d 0 + 4370009165
12  ???                           	0x00000001077e4734 0 + 4420683572
13  libjvm.dylib                  	0x0000000103aeab0e JavaCalls::call_helper(JavaValue*, methodHandle*, JavaCallArguments*, Thread*) + 1710
14  libjvm.dylib                  	0x0000000103b21bb7 jni_invoke_nonstatic(JNIEnv_*, JavaValue*, _jobject*, JNICallType, _jmethodID*, JNI_ArgumentPusher*, Thread*) + 748
15  libjvm.dylib                  	0x0000000103b1438b jni_CallVoidMethod + 363
16  libnativewindow_macosx.jnilib 	0x000000014e26b7ae 0x14e266000 + 22446
17          	0x00007fff92cf3fde __NSThreadPerformPerform + 279
18      	0x00007fff8591b881 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
19      	0x00007fff858fafbc __CFRunLoopDoSources0 + 556
20      	0x00007fff858fa4df __CFRunLoopRun + 927
21      	0x00007fff858f9ed8 CFRunLoopRunSpecific + 296
22           	0x00007fff96b9f935 RunCurrentEventLoopInMode + 235
23           	0x00007fff96b9f76f ReceiveNextEventCommon + 432
24           	0x00007fff96b9f5af _BlockUntilNextEventMatchingListInModeWithFilter + 71
25              	0x00007fff8e5e1df6 _DPSNextEvent + 1067
26              	0x00007fff8e5e1226 -[NSApplication _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 454
27  libosxapp.dylib               	0x000000014c5583aa -[NSApplicationAWT nextEventMatchingMask:untilDate:inMode:dequeue:] + 124
28              	0x00007fff8e5d5d80 -[NSApplication run] + 682
29  libosxapp.dylib               	0x000000014c55814d +[NSApplicationAWT runAWTLoopWithApp:] + 156
30  libawt_lwawt.dylib            	0x000000014c4e5517 -[AWTStarter starter:] + 905
31          	0x00007fff92cf3fde __NSThreadPerformPerform + 279
32      	0x00007fff8591b881 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
33      	0x00007fff858fafbc __CFRunLoopDoSources0 + 556
34      	0x00007fff858fa4df __CFRunLoopRun + 927
35      	0x00007fff858f9ed8 CFRunLoopRunSpecific + 296
36  java                          	0x00000001014a4463 CreateExecutionEnvironment + 871
37  java                          	0x00000001014a01ac JLI_Launch + 1952
38  java                          	0x00000001014a64c0 main + 101
39  java                          	0x000000010149fa04 start + 52

Thread 1:
[... many more threads]

Thanks for the report.

have you experienced this problem once you do you see it every time you close SNAP? By the way, do you use SNAP 4?
Probably the problem originates from one of the libraries we use. We also had some issues on Linux systems with the Worldwind library.
However, thanks for the report. We will keep track of it.

I do use SNAP 4.0 with updated modules. I have seen the problem several times, but not always.

Today (Monday, Sept. 12th) I tried to update to the 4.0.2 modules using the GUI, but when I tried to restart SNAP it crashed and the modules were not updated when I started SNAP. I quit SNAP and removed the ~/.snap/appdata ~/.snap/etc, ~/.snap/system folders and was able to apply the updates.

The next time I quit, it crashed again.

I too am facing a similar problem. I access snap on linux server via MacOS X Yosemite 10.10.5. Some of the button are not working. First it was buttons in the navigation pane and. After restarting SNAP, even file manager is also not responding to clicks. On terminal I see a list of errors.
In my case it does not quit but behaving weird, when some operations works at one time and then stop working on restarting.

Your issue is not the same. The problem I have is when running SNAP as a native MacOS application. The display is fine and the buttons work normally, but it crashes when I quit. You appear to be running SNAP as a native Linux application, but you don’t mention whether you are using a remote desktop technology such as VNC or using XQuartz on the mac (either directly by setting the DISPLAYvariable on the Linux server to the mac address or via an SSH tunnel). There are differences in the capabilities of a native Linux X server, the VNC Xserver, and a remote Xserver. If you are using XQuartz, you should make sure you are using the current version.

As it happens, I have access to a Linux server and run SNAP there using an ssh tunnel to display on XQuartz. I had to disable WorldWind, and in the terminal where I start SNAP I get messages “libEGL warning: GLX/DRI is not supported”, but the simple things I do (loading a band and making an image) with it work.

I tried disabling WorldWinds on MacOS El Capitan (after upgrading to the current modules). Since then I have not seen a crash on exit (three machines running MacOS 10.11.6).

Yes I am indeed using XQuartz. I resolved the issue, I am not sure how but I think some SNAP operation was running in the background on the other window. But strangely the issue stayed even after restarting the application via ssh tunnel using XQuartz. Restarting the computer helped. Thank you very much for your reply!
How are you upgrading your modules? How can I disable WorldWind in the terminal?

See snap-hang-on-start-on-centos-6-5-box. At best you need to move the WorldWind module to a backup location. You may also need to delete some directories under ~/.snap.

1 Like

Is this still an issue on MacOS?

I have not seen this problem recently. There have been updated to macOS, Java, and SNAP since I last saw the problem so I don’t know how it was solved.