SNAP S1A subset doesn't match WKT from Geometry

Hi all, I’m trying to batch process my subsetting of images and learned that the best way to do this was through geographic coordinates. I created a polygon in the original image, used ‘WKT from Geometry’ to get the coordinates and ran the tool; however, as shown in the image attached, the subset output doesn’t match the polygon I created. I’m not sure why - any help is much appreciated.

I just tried it with an original GRD product.

It worked.
Maybe you can give some more details. Have you used the Graph Builder and the Batch Processing in the GUI or have you used gpt from the command line for batch processing?
Does this happen with all products?

I move this topic also into the s1tbx category as it seems that it is more related to the S1 data.

Hi, I’ve used the graph building and batch processing in the GUI. I think I’ve just accepted that I won’t get the exact same subset, as frustrating as that is I can’t think of a reason why it doesn’t work! Thank you for your response.