SNAP Spectrum view no linestyle selection

Hi all in SNAP Spectrum view the linestyle selection is not available. I have tried with several different files and configuration and no line is shown. The deployable menu cannot be deployed. Thanks for your advice!

What kind of data are you using? I’ve tried with MERIS and Landsat8 and I was able to choose a line style.

spot take 5 data can not show the spectrum.

Probably the reason for this is that no wavelength information is provided for the bands.
Right click on a band, select Properties and specify the Spectral Wavelength.

I think you have downloaded the data in spot-dimage format and open just the tiff files, right? This spot-dimage format is not directly supported by SNAP. Maybe you can chose a different format.

Thanks for your swift reply! I am using Sentinel 2 data in xml format. I have tried at least with 10 different files and it doesn’t work…

Is it only showing Collecting spectral information…?

hmmm no, it is showing ‘spectral view’ screen with spectral spots but no line. Thanks…

sorry!!! yes, it is showing Collecting spectral information. Sorry, I’ve just seen it.

I think this indicates that you don’t have enough computation power. It can take some time till the spectrum is shown, even on more powerful system. If it seems to take endless time I think your system lacks probably memory.
What is your system configuration?

W7 32bit-Intel Core i5@2.8GHz 8GB RAM

Really? 32Bit Windows and 8GB RAM? So you are using only half the RAM.
And SNAP can only use 1.2GB RAM. This is not enough for working with Sentinel-2 data. For medium resolution data it might be sufficient but not for high resolution.
So I would suggest that you update to 64Bit.

You are right. I have another computer with this configuration: W7 64bit-Intel Core i7@3.07GHz and 6GB RAM. Do you think it will be enough? Thanks again and have a nice weekend.

Yes, this should be enough.
I wish you a nice weekend too.

Hi again there! I get the same result with the W7 64bit-Intel Core i7@3.07GHz and 6GB configuration…still the “collecting spectral information message”. Any idea of how i could solve this? The performance of this computer is normally good.

What happens if you don’t move the mouse for a while but position it in the view? Maybe a minute or two. Will it show the spectrum then?

Hi Marpet, you were right, after waiting >5 minutes I got the spectrum. I am a bit worried on the performance. I tried to select 4-5 pins and show spectrum and it didn’t appear in 2 hours. I think something is wrong with my configuration. How could I test the performance?Thanks!

This is really a lot.
The spectra of 5 Pins are shown within 20 seconds or so on my computer. I have a bit more memory but slower CPU.
Have you already tried the 3.0 release?
Maybe it will help to create a subset of the region and save it to disk before you further work with it.