SNAP - StaMPS Workflow Documentation

alright - this is possible.

You can use an external DEM by changing line 24

  <demName>SRTM 1Sec HGT</demName>

of this file coreg_ifg_computation_subset.xml (you find it in the graphs folder) with

  <demName>External DEM</demName>

How can I solve this problem which on the screen shoot please help me.

You got the mt_prep_snap syntax wrong:

mt_prep_snap <yyyymmdd> /home/username/.../INSAR_master_date/ DA

From what I can see, the error is caused by two mistakes:

  • You need a space between the date argument and the path to the master date directory;
  • Afterwards, you just need to supply one single value for the amplitude dispersion index D_A.

P.S.: I find the error message kinda funny, but better don’t tell Andy Hooper :wink:

1 Like

Thank you for your urgent replay.I really appreciated it. However, it does nt work even i make a correction on it

Just try mt_prep_snap 20141016 /home/abity/.../INSAR_master_date/ 0.4 1 1 and delete all the stuff afterwards.

For details, please see the snap2stamps-Manual.

Dear all,
I am running into an issue with 1st step of StaMPS processing - loading data into matlab. I am working with a Ubuntu 16.04 VM created using Virtual box. I have Matlab installed as well as StaMPS 4.1b and all the required tools. I have used the snap2stamps workflow for preprocessing the data using snap v7. All steps so far have run without problems and the interferograms all seem to be correctly created. However when I run the stamps(1,1) I get following error.

I have found a single reference to this error which suggested to use Linux, which I am using. Has anyone encounered this before? I have also reinstalled matlab and tried to see if all StaMPS scripts are the latest version, but without result.
Moreover the code above references version 4.0b, but I ahve never installed this version. I have downloaded and installed this StaMPS on clean VM few days ago using latest version dowloaded from the Github.

Another question I have is regarding preprocessing with SNAP 7. I have been recently told that there are certain “issues” but I have not been able to find a single reference as to what these should be. With the exepion to an update to the ESD parameters. Could anyone provide more information about this, if it is the case? Could the above error be caused by data preparation in SNAP 7?

I would be wery gratefull for any help. Thank you very much.

Thank you for your urgent replay. I also really again and again appreciated it.Another problem is facing me when I processing it

this is the directory of exported stamps and also the other is the installed software next to Ubuntu18 and Matlab18. I really thank you for your unlimited encouraging at all.

1 Like

The path in the command must be identical to the path where the files are located. Currently they are under INSAR_Master_Date-241016, but in the command you write INSAR_Master_Date so StaMPS will not find it.

I suggest to rename the folder to INSAR_20161024 following the convention in the documentation and use exactly that in the command. To separate the exported files from the processed files, make a new directory (e.g. work), navigate in it and start mt_prep_snap from there. This will create all new StaMPS processes and files there as long as you correctly give the full path to the input files in the command as suggested above

Thank you for your unlimited help. however still it cant work I faced the same problem.

your folder organization is still not correct: Inside the INSAR_20161024 directory you need to place the folders

  • geo
  • diff0
  • dem
  • rslc

which were exported from SNAP, no sub-folders. Currently, they are in INSAR_20161024/INSAR_Master_Date-241016 so StaMPS cannot find them.

here is the organized files inside the directory of INSAR_20141016 with respect the number of the files

the same thong is happening

looks like you are still having the files in the old folder:

and not in INSAR_20161024

okay sir yes you are right I am really appreciating you great patient well kindness at all. when I processing it again it looks like this one

if the commands are not found, the StaMPS_config file is not correctly pointing to the location of the scripts (bin and matlab) - did you move it somewhere else?

here re both the bash and tcsh files

the files of (bin and matlab) are located at

the commands wich are not found (e.g. psclonlat or selpsc_patch) are all located in the src folder

This indicates that they were not included in the installation of StaMPS. Did you compile them correctly as described here?
Please carefully go through the steps listed under “Installing for processing in stamps” - especially this one is important:

cd /src
Make install
1 Like

when I install stamps4.1b it looks like this one

you are not following the guidelines…

first you navigate to the src folder, then you simply type make and make install
the apt-get install command will not work here.

Maybe you can ask a colleague who is more familiar with linux and helps you with it.