SNAP stuck in update loop

With the recent release of S1TBX 9.0.3, SNAP is now stuck in a loop trying to install all updates. Updating my existing installation on Windows, the software first gave me an error of incompatible plugins, then goes in a loop trying to install one last update “S1TBX Utility Operators” (installs it, restarts the software, intalls again).
I have done a fresh install and now it does not try to update but immediately restarts the software once I close it.
After restart of the system and starting SNAP, the loop trying to install the above plugin restarts. I had to end SNAP via the task manager.

I just made this update too and it works for me without any problem.
Sometimes during an update, the download gets corrupted and then strange things happen.
Even though you tried already a fresh install, please try the following.

If you are on Windows:
Press WINDOWS+R and type appdata in the upcoming dialog and press enter.
Then navigate to:
On Linux the folders are at <UserDir>\.snap\system\. I think.
Delete the folders:

  • modules
  • update
  • update_tracking

This will reset your SNAP to the state of the initial installation without updates.

Then you can try install the latest updates again.

This worked! Thanks a lot for the fast help @marpet.

1 Like