SNAP update 9.x to 9.04 - Fails to update several models

Great STEP community,

Can anyone help me understand what should be done to correct the warnings (txt file in attachment) that prevents to me to update several modules from version 9.01 to other versions eg. 9.02 or 9.04.
I’m using LightDM Distro: Linux Mint 20.3 Una base: Ubuntu 20.04 focal (today I made a usrmerge conversion to system (maybe this is the problem) ) -

some of the warning example:

Blockquote
Warning - could not install some modules: S1TBX Analysis Tools UI - The module Ceres JAI Library was requested in version >= 9.0.4 but only 9.0.1 was found. S1TBX Analysis Tools UI - The module SNAP Desktop Rich Client Platform was requested in version >= 9.0.4 but only 9.0.1 was found.
(…)
SLSTR/AATSR Regridding Tool - The module SNAP Core Library was requested in version >= 9.0.2 but only 9.0.1 was found. Sentinel-3 Toolbox Kit Module - The module Ceres Runtime Library was requested in version >= 9.0.2 but only 9.0.1 was found. Sentinel-3 Toolbox Kit Module - The module SNAP Desktop Rich Client Platform was requested in version >= 9.0.2 but only 9.0.1 was found. 36 further modules could not be installed due to the above problems.

all the other warnings in
sanp_updatde_warnings.txt (49.7 KB)

Maybe I should unistall SNAP and install it from scratch ?

Thank you

Yes, this is probably the best solution. It seems that during download of the new updated modules something went wrong.
If the error persists, please report it again.

Thank you marpet.
I did get the following warning message also:
warning_message_2

And after restarting (clicking ok, on the other message)

SNAP desktop version seems to be 9.04
snap_version

But S1TBX is still 9.01:
s1tbx

So a new installation is required as you suggested.

If it now starts well, then no new installation is necessary. The latest version of S1TBX is 9.01

1 Like

Ok. It starts well. Thank you marpet for your insight :upside_down_face:

1 Like