SNAP update errors

While updating SNAP, after installation and restart, the following error message pops up when starting SNAP

I doubt that SNAP will be running smoothly if all those modules are disabled. Does anyone know a workaround for this?

Probably this was an issue with the server. Could you update SNAP by now?

Dear @marpet, I have been trying to update SNAP 9.0 GUI on WSL2 from last 2 days without any success. It shows following errors despite trying multiple times. I also tried to change the connection setting but to no avail. Could u please take few moments of your precious time in pointing out the possible cause of it. Thanking you.

unable to connect

This is strange. I haven’t used WSL2 in GUI mode yet. So, I have no experience with using SNAP with WSL2.
I only executed gpt from the shell and it worked.
To update SNAP only a plain http connection is used. Nothing special.
Is the internet connection working at all for the WSL2?

Thanks, yes internet was working fine. The issue got resolved after 5 days of all by itself.