SNAP update in unattended mode : proxy setting problems

Hello everyone,

I’m trying to install SNAP v5.0 on a CentOS 7 64 bits machine using unattended mode and a response.varfile to set my parameters using the following command:

$ sh -q -varfile response.varfile

with the following response.varfile :


The installation is doing just fine.

My problem occurs during the update using the following command :

$ snap --nosplash --nogui --modules --update-all

the proxy is not correctly set and the command returns :

Server returned HTTP response code: 407 for URL:

I tried to manually configure the proxy in the GUI : this is working and the updates may be done in the GUI.
But I was unable to do the same and configure it using unattended mode since I don’t want to use the GUI.

I tried to add the following options in the response.varfile:


without any success.

What did I miss?
Is that a correct way to manually configure the proxy?
Is there any configuration file where the information about the proxy may be provided?

Thanks for your help,
Christophe T.

The response.varfile is only used by the installer. For SNAP you have to provide the configuration differently.
I’ve updated the wiki page Update SNAP from the command line . See the last section.

Please help to solve the issue I’ve stuck.
I try to update SNAP from 5.05 to 5.07, but it can’t reach the update service. SNAP uses preferences from Chrome, I didn’t change them since the last successful update and test connection is ok.
Meanwhile, I can reach update site in my Chrome browser.
I tryed to update SNAP from the command line, but wasn’t succeed too.
May me is it possible to download files manually and update SNAP after it from a local drive? What can I do else?


Yes you can download the modules manually from here:

I’m not sure if the following will work.

snap --update modulename.nbm

In the GUI you can select the download files.

Thank you for an answer Marpet.
I’ve managed to download modules, but I can’t choose my local storage as a source from download in Update center customizer window. SNAP warns that URL is incorrect.

You can select the nbms in the Downloaded tab and then clicking on Add Plugins.

I think you tried to add your download location as a new provider.
Try it this way:

You will need the updates.xml.gz file. It is located on our server too.

Thank you very much, Marpet. You gave a very good advice, as you always do. The Add plugins method works well for me.