SNAP updates not executing

Hi everyone,

I have had SNAP running on my windows 7 machine since it first came out. This computer is clean with plenty of memory and space for this type of work. Everytime opportunities to update show up in the bottom right hand corner, the program has worked fine executing those updates with no issues.

This morning I saw that 8 updates were available and ran them per usual. However, the updates won’t complete and I am not sure why. The bottom of the screen says “Downloading plugins” but it fails 70-80% of the way through. Because of that, I can’t do anything in SNAP. Coregistering doesn’t work properly, interferogram generation doesn’t work properly either. I tried unistalling everything, re-downloading SNAP fresh from the ESA website and reinstalling SNAP, and obviously shutting down/restarting. I have also tried updating from the top menu, under help. That made no difference. The same issues stand. There are 8 updates that need to happen, and they won’t go through the update. I also tried ignoring the updates and continuing my work. Same issues, nothing works properly. In fact, clicking any module or button in the program is really really slow, when everything is usually very fast. I do blame the slowness on the program not being up to date, but I am all ears at this point.

Any ideas on how to get SNAP fully updated and working properly again?

Thanks in advanced.


Here is an update:

I tried re-installing again and running the updates. Looks like the updates went through the process. After that I restarted and opened SNAP. I did the normal drag and drop to add a dataset, which didn’t work. Immediately an exception showed up. A red dot showed up at the bottom right of the screen. Here is what it says below.Unexpected%20Exception

Have a look at this

Yes, the updates have been problematic in the recent past.
We have observed unusual high traffic on the server which affects the updates of SNAP, especially in the time between 10:00 pm and 9:00 am CET.
So it might work if your try to reinstall later.

The traffic is not an attack, but there are unusual requests for the DEM files.
Probably, someone is processing a lot and is not using the cache for the DEM.
We are working on it.

1 Like

Thanks for the explanation. This makes sense.

So, do you think I should just keep uninstalling and reinstalling during the off peak hours until everything is working properly again?

Yes, I hope this workaround will help