SNAP urgent problem

Good morning everyone,

I am facing a sudden and “mysterious” problem today: I have opened my snap 6.0 as I daily do, but today I can not open the File menu and if I try to access a product (Sentinel2 or Sentinel3 for example) nothing appears in the Product Explorer window. I did not make any update of my Windows 10 so nothing has changed since I last used snap yesterday. What can be the reason?
Update : yesterday I tried to read a geotiff that was corrupted and since that moment SNAP seems to be blocked on that error, whenever I try to open even a good product I get always the same error related to yesterday .
here attached, the log file .

messages.log (74.1 KB)

Update the SNAP, from help tab update and see if it solves the problem, SNAP, V. 6.0.1

A new beta SNAP 7. V. Will be released in the end of June, 2019,

Source of the post

However, the test version SNAP 7.0 Official release is available,

Source of the post

Here SNAP should handle such an error more gracefully. I will create an issue for this.
Antonio, you can edit the preferences manually to fix it.
Press WINDOWS+R and type appdata in the upcoming dialog.
The navigate to:
There you find Open it in a text editor.
remove the corrupted path from the property recently_opened_products.

Afterwards SNAP should work again.

The issue I’ve created.


This is great. Thanks Marco!