SNAP v7 S1 ifg water masking

In SNAP v6 (on MacOS), the “Interferogram Formation” function would automatically apply a water mask, setting the phase and amplitude over the ocean to zero. When I run the same function in SNAP v7, it is not masking out the ocean. I did not see an option to enable the water mask in v7. Is there a way to apply it? I am working on land at the coast.

Right click on the phase band and select Properties. In the Properties window, select “No-Data Value Used” to see if that helps.

@jun_lu Thanks for the suggestion. I tried that and it made no difference.

I found a function Raster->Masks->Land/Sea Mask that has an option to mask out the sea. It seems to only offer the use of the 3-arcsecond SRTM data for automatic masking, which is somewhat coarse for the area I am studying as I am processing my interferogram at the full resolution. It also gives the option of providing your own vector dataset.

I’ve tried on my computer with the data I have but cannot repeat the problem. Could you post your processing chain and data sets used so that I can try them on my computer? Thank you