SNAP v8: cannot import shapefile to overlap with raster

I have a lake boundary and raster file of the same area. In SNAP version 7, I can open the raster then import the shapefile to overlap, using menu: Vector --> Import --> ESRI shapefile.
While I do the same operation with the same files, SNAP version 8 report the following error:

I tried reproject the shapefile to different projection, same issue. Any clue?
Also, I notice SNAP 7/8 both minimizes the window everytime after a successful operation (e…g, open a file), what is wrong?

raster image information:

vector shapefile information:

SNAP v7 can overlap sucessfully:

can you please share the shapefile of the lake?

thank you and sorry for the delay. please find the shapefile as attached. (679.1 KB)

thank you for sharing.

Regarding this point:

This happens at my computer as well - should not cause an error.

But I receive the same message in SNAP


However, when I apply a small buffer to the polygon, everything works. There might be some sliver geometries or invalid definitions which are causing the problem.

I ran “fix geometries” by QGIS on the file and it works as well, please try: (697.7 KB)

Oh, Thank you Braun for the help ! and let me try it as well! I did not think of the geometry issue, as I seems to able to open in SNAP 7 without a problem from myside.