Snap2stamps error

Thank you so much ABraun it’s working now.

Dear ABraun
S1-TOPS split is not running. please check it once. I installed all the updates now it is SNAP8.0.3.

I can’t see an error.
Maybe your disk is full? Restatting SNAP could also help.

No still 2TB free space is present, it took around 10 minutes to complete this step.

While using Python wrappers(snap2stamps) also taking lot of time to process the above step. I’m not getting any error but the processing time is very high for single file (Previously it was 1 minute for 1 image and now it is 10 minutes for 1 image).
Please check it once.

this is because snap2stamps makes use of graphs which consume more memory than single steps.

shown in above table AOI BBOX DEFINITION, For suppose i didn’t enter these lat lon values.
Instead of using coreg_ifg_computation_subset.xml i’m using coreg_ifg_computation.xml is it ok?

My intention is, i want to process all the slaves images AOI with respect to master AOI without giving lat long values
Is it possible?

Don’t modify anything except for the config file. There you enter the coordinates you need for your AOI. The scripts do the rest.

Thank you ABraun.

Getting also same error in matlab processing.
18 of 18 interferograms processed. used latest version of SNAP 8.0.3


if it happens during step(1,1), please try this: New StaMPS release (4.1-beta)

There is a file to replace, keep the old one as a copy, and run again.

Yes, it is happened during step(1,1).
I tried the New release file, same error.
I have also the updated (New release file), line to line matched code.

have you checked if all interferograms look alright? Sometimes SNAP produces empty data which causes problems in StaMPS

I processed 20 Sentinel-1 satellite images SLC type, which i got 7 interferogram images.
Isn’t it suffice data to process StaMPS PSI processing?

actually, if you have 20 images you should receive 19 interferograms.

Please let me know, I think some issue in processed data. After run the command ‘mt_prep_snap’, only PATCH_1 and other file created.

Inside the PATCH_1 folder, some files having no data.

I think this is creating the issue in matlab processing.
Please guide me , what i have to do?


The number of patches is defined in the mt_prep_snap command. In the manual (chapter 4), it ends with 3 2 which means that three rows and two colums area created (=6 patches). If you don’t add any numbers, all data is processed within only one patch.

Thanks for sharing this info, I used command for 6 patches. All patch folder having null data (0 bytes)
Screenshot from 2021-05-31 19-34-39Screenshot from 2021-05-31 19-34-58
Is it OK?

Finally, I found the issue, now i got the data in all patches, after removing the all zero mean amplitude file in rslc folder.
Completed Stamps(1,1) process in matlab

1 Like