Snap2stamps package: a free tool to automate the SNAP-StaMPS Workflow

Well… that error could also for the folders you want to read and write
As it is the first time somebody reporting such error… I believe that it is not related to snap2stamps package itself but on you want them to read and write

The script does not check the integrity of the files found, so it will try to recreate all. You can avoid this by removing from the slave splitting folder the ones already processed.
I hope this helps


Thank you so much. Fortunately, you point worked very well :muscle:

Yes, I know. Exactly, it is not related to the package. I will ask the RSS support team of to help me fix it.

@mdelgado Sorry, I put the package in running and found in the command that the processing is doing successful but something warning about the dem file made me worried. Could you please see the following picture and let me know it is important or not?

you have to check the coregistered products: Open them in SNAP and check if the coregistration was successful as described in this post. Also, check if the included elevation band contains data. If not (it will appear purple only), the removal of topographic phase was not carried out correctly.


The error in fact could be due to any issue with the place from where SNAP tries to retrieve the SRTM DEM, which seems to be hosted by

Can any of you @marpet, @lveci confirm that the repository is still valid?

1 Like

@ABraun Thank you for your nice suggestion.

@mdelgado Exactly but I run the package for two study areas. I didn’t have this warning in first one but in the second study area, where is in Indonesia, I faced this message. So, I was worried about the coverage of SRTMGL1 over this area :thinking:

Dear Braun,

I checked your suggestion and found the elevation band in the correct style but when I finished the time-series processing by stamps, I got my results as follows:

They are strange especially in the upper half of the image. Do you think it happened due to that warning about the DEM and anything for coregistration?

@mdelgado Could you please look above figures and let me know your comments?

how does the coregistered image look like in snap?

Unfortunately, I have to delete all ifg and coreg files because of my storage capacity limitation in my user at RSS cloudtoolbox. I must download the dataset again and follow the progress.

1 Like

Wondering if the problem could have been in the master image.

Please check step by step the intermediate products before proceeding

1 Like

Which problem do you think maybe happen in the master image?

It could had happened during the master split, just for guessing. It must be something happening to each pair, hence it could be either master or Dem related

@mdelgado I checked the availability of two tiles of SRTM which cover my study area through these links:

Unfortunately, I couldn’t find them through these links. So, I think my issue in the results will be related to the lack of DEM files. How can I follow this issue? Should I change the used DEM to another one in the snap2stamps package? @marpet @lveci

You can download them and put them in the target folder specified in the snap configuration files for auxiliary data.

That should work

@mdelgado Sorry, I said I couldn’t find them in these links. It means they are not available to use in processing.

Did you give this point about other DEMs?

I know what you said, but you can check the availability of these tiles on other sources.
I do not know by heart from where but probably USGS or other official sites may offer the srtm Dem 1arc, or you can choose other Dem where may have the tiles over your site

I am processing a time-series of S1 images over my study area using the snap2stamps. When I got the results for one slave-master pair, I checked the generated ifg and found a strange situation there. You can see the interferogram:

I chose two bursts from each of two images, which must be assembled to cover my study area. I checked the topography and found it OK:

Could you please guide me in this situation? As you can see, the package show a successful progress for this pair:

Could you show the coregistered stack master slave?

The package shows the successful operational steps but not the integrity of the content. That is on the user to check that master, slaves and other products are fine after each of the steps.

I hope this helps
Merry Christmas