Snap2stamps package: a free tool to automate the SNAP-StaMPS Workflow

Sorry, I don’t understand
You split and apply orbit to the master, then use this product in the config file.
The scrips prepare the slaves accordingly

in this pm you said " *the AOI can range over various bursts, but it must be within one sub-swath. The master you prepare should be reduced to the number of bursts which entirely cover the AOI, the rest is done by the scripts."
For this reason, I got a little confused about why we need to reduce the burst number of master image, so as you mentioned after splitting and apply orbit to the master, the scrips prepare the slaves accordingly

Maybe @mdelgado can confirm if the bursts of the master have to be reduced manually in the preprocessing or if this is done by the AOI definition in the config file.

I have added time ago an script that splits the master based on the AOI, not needing to do it manually using SNAP GUI.

However, the suggested procedure remains using SNAP GUI as the user may identify properly that his AoI is fully covered.


Dear all,

I have got the PS result successfully by using Snap2stamps package in the last year.
Now, I want to process 14 images of the same study area in the different time period. The step of “stamps export” take a very long time (over 24 hr) for processing the first interferogram and didn’t show any error message.

I have check all results of coreg and ifgs, but the problem still exit.
Could anyone help me to solve it? Thank you very much!

please have a look here: Problem in the last part of snap to stamps

1 Like

Hi ABraun,

Thank you for replying my question.
But I have selected “SRTM 1Sec HGT (AutoDownload)” as DEM instead of SRTM 3Sec in all steps of Sanp2stamps package.
Such as following:

I’m not sure is there anything I misunderstanding?

Thank you very much.

this has worked for most users, but some report that the error remains. Have you installed the latest version of SNAP including all updates?

No, the version I used is v7.0.
And I don’t have the authority to update to the latest version of that computer now …
I will try to process the images step by step in snap software without snap2stamps package, although I don’t know it will help or not.

sorry, we cannot grant for correct processing based on outdated versions.

I know, still thanks a lot!

Hi ABraun,
I have installed the latest version of SNAP and run again with SRTM 1Sec. The problem is the same…

please also change the SRTM 3Sec address in the configuraiton file for a test, although SRTM 1Sec was used.
You might also check the SRTM 1Sec folder for corrupt files.


I change the SRTM 3Sec address in the configuration file although SRTM 1Sec was used this time, and it seems work!
Thank you very much!

1 Like

strange, right?

@jun_lu Can you (or someone who developed it) please again check where in the StaMPS export SNAP tries to access the SRTM 3 data? Shouldn’t be necessary actually…

We will look into it

1 Like

ProjectedDEM has been modified to set SRTM 1Sec HGT as the default DEM. The code has been checked in to GitHub. Hope that fixes the problem


Thank you sir, please provide GitHub link.

This means you can automatically implement it with the next update

When I run the python coreg_ifg_topsar py project.conf script, it does not separate the # AOI BBOX DEFINITION for me. And it separates the images only according to the MASTER=/application/pi/nazlina/Sofiyan/master/S1A_IW_SLC__1SDV_20181119T030104_20181119T030131_024651_02B56D_649E_split.dim
, which has greatly increased the processing volume, can anyone advise me what to do?