Snap2stamps package: a free tool to automate the SNAP-StaMPS Workflow

please also change the SRTM 3Sec address in the configuraiton file for a test, although SRTM 1Sec was used.
You might also check the SRTM 1Sec folder for corrupt files.


I change the SRTM 3Sec address in the configuration file although SRTM 1Sec was used this time, and it seems work!
Thank you very much!

1 Like

strange, right?

@jun_lu Can you (or someone who developed it) please again check where in the StaMPS export SNAP tries to access the SRTM 3 data? Shouldn’t be necessary actually…

We will look into it

1 Like

ProjectedDEM has been modified to set SRTM 1Sec HGT as the default DEM. The code has been checked in to GitHub. Hope that fixes the problem


Thank you sir, please provide GitHub link.

This means you can automatically implement it with the next update

When I run the python coreg_ifg_topsar py project.conf script, it does not separate the # AOI BBOX DEFINITION for me. And it separates the images only according to the MASTER=/application/pi/nazlina/Sofiyan/master/S1A_IW_SLC__1SDV_20181119T030104_20181119T030131_024651_02B56D_649E_split.dim
, which has greatly increased the processing volume, can anyone advise me what to do?

Here is the link You can update and build your SNAP if it is built from the source code


for the coregistration and interferogram formation, the extent of the split master product is used. The clipping is done at a later stage.
Also, the master should end with split_orb.dim


with the snap2stamp package is it possible to use COSMO-SkyMed data?
It would simply be to apply the two commands?



or is it necessary to do the co-registration directly from the SNAP application?

no, you simply coregister all products (first input) and apply interferogram generation (second input), and use both stacks in the StaMPS export. The python scripts will not work here because they are designed for S1 IW data.

1 Like


where or in what file or folder does this data appear in StaMPS?

1 Like

Why can’t I run this script? when I run python project.conf code, it only creates an empty directory named of INSAR_2019… for me. Why does it not create files for me? Why does the script not work?Please tell me how to fix this problem?

have you seen this? A process related to digital elevation models is taking forever to finish
Please install the latest update to exclude this as an error source.

If this does not bring a solution: Do the interferograms look alright?

Previous steps performed without error, only this step does not run. How can I find the latest update?

Menu > Help > Check For Updates

I tried again. it did not work.

What about that?

Yes, they look good.